Author Topic: Hostname adding 127.0.0.1  (Read 501 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Hostname adding 127.0.0.1
« on: January 27, 2019, 09:21:19 AM »
Hello

I just installed cwp-pro but everytime i change hostname it always add 127.0.0.1

ex: us.domainname.com127.0.0.1

I already reboot etc, still same

Offline
***
Re: Hostname adding 127.0.0.1
« Reply #1 on: January 27, 2019, 06:39:02 PM »
This already happened to me.

I just could solve it changing manually the file '/etc/hostname', and executing:

Code: [Select]
chattr +i /etc/hostname

Regards,
Netino

Offline
*
Re: Hostname adding 127.0.0.1
« Reply #2 on: April 24, 2019, 03:12:17 AM »
Hello

I just installed cwp-pro but everytime i change hostname it always add 127.0.0.1

ex: us.domainname.com127.0.0.1

I already reboot etc, still same


I solved it by putting a dot at the end.

Try  us.domainname.com.

Offline
**
Re: Hostname adding 127.0.0.1
« Reply #3 on: April 29, 2019, 10:49:30 AM »
Basically when you purchase a kvm/OpenVZ vps from vendor , they provide a hostname with private ip for management . the ip is providing by aliasing.

The hostname can be configured as follows:
Static host name assigned by sysadmin. For example, “server1”, “wwwBot2”, or “host.datahead.biz”.
Transient/dynamic host name assigned by DHCP or mDNS server at run time.
Pretty host name assigned by sysadmin/end-users and it is a free-form UTF8 host name for presentation to the user. For example, “Rubel’s netbook”.

I had the same issue , and I have fixed the issue . Please follow the below guide , it's really helpful .

Set Hostname Permanently
https://www.awsmonster.com/2019/01/cwp-installation-perquisite-set.html

Disable Network Manager & Set Static IP
https://www.awsmonster.com/2019/01/cwp-installation-perquisite-disable.html

And Finally use the command
Code: [Select]
chattr +i /etc/hostname