Author Topic: Name Server Not Working  (Read 675 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Name Server Not Working
« on: July 24, 2017, 04:52:51 AM »
here is my domain

https://intodns.com/ppdb-online.web.id

I totally have no idea what I did wrong.

Here is what I did so far :
1. Add Glue Record on Registrar (ns1.ppdb-online.web.id, ns2.ppdb-online.web.id)
2. Set ppdb-online.web.id nameserver to ns1.ppdb-online.web.id, ns2.ppdb-online.web.id
3. in CWP. DNS Function -> Edit nameserver IP.
ns1.ppdb-online.web.id 139.99.2.142
ns2.ppdb-online.web.id 139.99.2.142

The domain still won't get resolved. What did I do wrong ?

Offline
***
Re: Name Server Not Working
« Reply #1 on: July 24, 2017, 06:36:22 AM »
you can use this site for testing
http://leafdns.com/index.cgi?testid=A99064F4

this is issue on your server since dns part of your domain provider is ok, now what you need to do is set in cwp your nameserver and edit dns zone file ppdb-online.web.id tu use that nameservers

Your nameservers are:
ns1.ppdb-online.web.id
ns2.ppdb-online.web.id
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

Offline
*
Re: Name Server Not Working
« Reply #2 on: July 24, 2017, 10:51:51 AM »
you can use this site for testing
http://leafdns.com/index.cgi?testid=A99064F4

this is issue on your server since dns part of your domain provider is ok, now what you need to do is set in cwp your nameserver and edit dns zone file ppdb-online.web.id tu use that nameservers

Your nameservers are:
ns1.ppdb-online.web.id
ns2.ppdb-online.web.id

I believe I already set it right.


Code: [Select]
; Panel %version%
; Zone file for ppdb-online.web.id
$TTL 14400
ppdb-online.web.id.      86400      IN      SOA      ns1.ppdb-online.web.id.      yokowasis.gmail.com.      (
      2017072400 ;serial, todays date+todays
      86400 ;refresh, seconds
      7200 ;retry, seconds
      3600000 ;expire, seconds
      86400 ;minimum, seconds
      )


ppdb-online.web.id.      86400      IN      NS      ns1.ppdb-online.web.id.
ppdb-online.web.id.      86400      IN      NS      ns2.ppdb-online.web.id.
ppdb-online.web.id.      0      IN      A      139.99.2.142
localhost.ppdb-online.web.id.      0      IN      A      127.0.0.1
ppdb-online.web.id.      0      IN      MX      5      ppdb-online.web.id.
mail      0      IN      CNAME      ppdb-online.web.id.
www      0      IN      CNAME      ppdb-online.web.id.
ftp      0      IN      CNAME      ppdb-online.web.id.
;      Add      additional            below      this      line
ns1      86400      IN      A      139.99.2.142                 
ns2      86400      IN      A      139.99.2.142                 



Is there something I am missing here ?

Thanks

Offline
*
Re: Name Server Not Working
« Reply #3 on: July 24, 2017, 01:55:11 PM »
ppdb-online.web.id is currently pointing to 89.37.67.130 IP address.

As per intodns link https://intodns.com/ppdb-online.web.id 

ppdb-online.web.id domain name is using uk1/uk2.bimasoft.web.id nameservers at registrar end and ns1/ns2.bimasoft.web.id at server end which are mismatched and ns1/ns2.bimasoft.web.id doesn't exists at registrar end.

So you will need to fix this part first.

Once done then try to add NS1 and NS2 at 89.37.67.130 server end.
https://www.24x7servermanagement.com/
Server Management, Server Security, Server Monitoring.
India's Leading Managed Service Provider !!

Offline
*
Re: Name Server Not Working
« Reply #4 on: July 24, 2017, 02:01:08 PM »
ppdb-online.web.id is currently pointing to 89.37.67.130 IP address.

As per intodns link https://intodns.com/ppdb-online.web.id 

ppdb-online.web.id domain name is using uk1/uk2.bimasoft.web.id nameservers at registrar end and ns1/ns2.bimasoft.web.id at server end which are mismatched and ns1/ns2.bimasoft.web.id doesn't exists at registrar end.

So you will need to fix this part first.

Once done then try to add NS1 and NS2 at 89.37.67.130 server end.

Yeah, I just want to make sure that my registrar do the right thing. So I point it to the cPanel. and it Works. The domain got resolved easily. I guess something wrong with my CWP settings. I wonder which settings. I will revert back the name server.

Do you see anything wrong with my settings above ?

Offline
*
Re: Name Server Not Working
« Reply #5 on: July 24, 2017, 05:57:57 PM »
ppdb-online.web.id is currently pointing to 89.37.67.130 IP address.

As per intodns link https://intodns.com/ppdb-online.web.id 

ppdb-online.web.id domain name is using uk1/uk2.bimasoft.web.id nameservers at registrar end and ns1/ns2.bimasoft.web.id at server end which are mismatched and ns1/ns2.bimasoft.web.id doesn't exists at registrar end.

So you will need to fix this part first.

Once done then try to add NS1 and NS2 at 89.37.67.130 server end.

Now it's back to
ns1.ppdb-online.web.id and
ns2.ppdb-online.web.id.

My server IP is 139.99.2.142. I already have added the ns1 and ns2 record. Yet the domain still unresolved.

Offline
*
Re: Name Server Not Working
« Reply #6 on: July 24, 2017, 06:41:38 PM »
Dig Result

Code: [Select]
[root@racksx ~]# dig ppdb-online.web.id @localhost

; <<>> DiG 9.9.4-RedHat-9.9.4-50.el7_3.1 <<>> ppdb-online.web.id @localhost
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 46777
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 3
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;ppdb-online.web.id.            IN      A

;; ANSWER SECTION:
ppdb-online.web.id.     86400   IN      A       139.99.2.142

;; AUTHORITY SECTION:
ppdb-online.web.id.     86400   IN      NS      ns1.ppdb-online.web.id.
ppdb-online.web.id.     86400   IN      NS      ns2.ppdb-online.web.id.

;; ADDITIONAL SECTION:
ns1.ppdb-online.web.id. 14400   IN      A       139.99.2.142
ns2.ppdb-online.web.id. 14400   IN      A       139.99.2.142

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Mon Jul 24 14:39:41 EDT 2017
;; MSG SIZE  rcvd: 131

[root@racksx ~]#

Offline
*
Re: Name Server Not Working
« Reply #7 on: July 25, 2017, 09:30:11 AM »
Can you try to recreate account for ppdb-online.web.id domain name on CWP and see how it goes?
https://www.24x7servermanagement.com/
Server Management, Server Security, Server Monitoring.
India's Leading Managed Service Provider !!

Offline
*
Re: Name Server Not Working
« Reply #8 on: July 25, 2017, 10:07:23 AM »
Can you try to recreate account for ppdb-online.web.id domain name on CWP and see how it goes?

Yeah I tried it a couple times but no avail. I just reinstalled my vps using vestacp, it works fine. The domain is resolved. I wonder what's wrong with my CWP Installation.

Still not working
« Last Edit: July 25, 2017, 10:12:44 AM by yokowasis »

Offline
***
Re: Name Server Not Working
« Reply #9 on: July 25, 2017, 04:51:43 PM »
you need to check your zone file ppdb-online.web.id and add there ns1, ns2 and ns3 A records.
don't forget that you need to have this also in your dns zone for domain ppdb-online.web.id

Code: [Select]
ppdb-online.web.id.      86400      IN      SOA      ns1.ppdb-online.web.id.      yokowasis.gmail.com.      (
and this
Code: [Select]
ppdb-online.web.id.      86400      IN      NS      ns1.ppdb-online.web.id.
ppdb-online.web.id.      86400      IN      NS      ns2.ppdb-online.web.id.
ppdb-online.web.id.      86400      IN      NS      ns3.ppdb-online.web.id.

after you checked all then restart dns/bind server.

One more thing that could be is that your CSF firewall has no open tcp/udp port 53 so you can check that also if all other is fine.
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

Offline
*
Re: Name Server Not Working
« Reply #10 on: July 25, 2017, 04:55:54 PM »
you need to check your zone file ppdb-online.web.id and add there ns1, ns2 and ns3 A records.
don't forget that you need to have this also in your dns zone for domain ppdb-online.web.id

Code: [Select]
ppdb-online.web.id.      86400      IN      SOA      ns1.ppdb-online.web.id.      yokowasis.gmail.com.      (
and this
Code: [Select]
ppdb-online.web.id.      86400      IN      NS      ns1.ppdb-online.web.id.
ppdb-online.web.id.      86400      IN      NS      ns2.ppdb-online.web.id.
ppdb-online.web.id.      86400      IN      NS      ns3.ppdb-online.web.id.

after you checked all then restart dns/bind server.

One more thing that could be is that your CSF firewall has no open tcp/udp port 53 so you can check that also if all other is fine.

it's all there
Code: [Select]
; Panel %version%
; Zone file for ppdb-online.web.id
$TTL 14400
ppdb-online.web.id.      86400      IN      SOA      ns1.ppdb-online.web.id.      yokowasis.gmail.com.      (
      2017072511 ;serial, todays date+todays
      86400 ;refresh, seconds
      7200 ;retry, seconds
      3600000 ;expire, seconds
      86400 ;minimum, seconds
      )


ppdb-online.web.id.      86400      IN      NS      ns1.ppdb-online.web.id.
ppdb-online.web.id.      86400      IN      NS      ns2.ppdb-online.web.id.
ppdb-online.web.id.      86400      IN      NS      ns3.ppdb-online.web.id.                 
ppdb-online.web.id.      0      IN      A      139.99.2.142
localhost.ppdb-online.web.id.      0      IN      A      127.0.0.1
ppdb-online.web.id.      0      IN      MX      5      ppdb-online.web.id.
mail      0      IN      CNAME      ppdb-online.web.id.
www      0      IN      CNAME      ppdb-online.web.id.
ftp      0      IN      CNAME      ppdb-online.web.id.
;      Add      additional            below      this      line
ns1.ppdb-online.web.id.      1800      IN      A      139.99.2.142                 
ns2.ppdb-online.web.id.      1800      IN      A      139.99.2.142                 
ns3.ppdb-online.web.id.      1800      IN      A      139.99.2.142                 

My firewall is off. I think we can rule that out.


Now that I think of it. I am on OVH Network. Do you think it has anything to do with this ?
« Last Edit: July 25, 2017, 04:57:50 PM by yokowasis »

Offline
***
Re: Name Server Not Working
« Reply #11 on: July 25, 2017, 05:08:40 PM »
it could be if they have nat-ed network and port access restrictions...but you should see that in your panel
When running test on your server it doesn't show any output meaning that this can be port restriction.


~ $ dig a ppdb-online.web.id @139.99.2.142

; <<>> DiG 9.10.3-P4-Ubuntu <<>> a ppdb-online.web.id @139.99.2.142
;; global options: +cmd
;; connection timed out; no servers could be reached
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

Offline
*
Re: Name Server Not Working
« Reply #12 on: July 25, 2017, 05:23:36 PM »
it could be if they have nat-ed network and port access restrictions...but you should see that in your panel
When running test on your server it doesn't show any output meaning that this can be port restriction.


~ $ dig a ppdb-online.web.id @139.99.2.142

; <<>> DiG 9.10.3-P4-Ubuntu <<>> a ppdb-online.web.id @139.99.2.142
;; global options: +cmd
;; connection timed out; no servers could be reached

Here is the output

Code: [Select]
[root@racksx ~]# dig a ppdb-online.web.id @139.99.2.142

; <<>> DiG 9.9.4-RedHat-9.9.4-50.el7_3.1 <<>> a ppdb-online.web.id @139.99.2.142
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 50233
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 3, ADDITIONAL: 4
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;ppdb-online.web.id.            IN      A

;; ANSWER SECTION:
ppdb-online.web.id.     0       IN      A       139.99.2.142

;; AUTHORITY SECTION:
ppdb-online.web.id.     86400   IN      NS      ns3.ppdb-online.web.id.
ppdb-online.web.id.     86400   IN      NS      ns1.ppdb-online.web.id.
ppdb-online.web.id.     86400   IN      NS      ns2.ppdb-online.web.id.

;; ADDITIONAL SECTION:
ns1.ppdb-online.web.id. 1800    IN      A       139.99.2.142
ns2.ppdb-online.web.id. 1800    IN      A       139.99.2.142
ns3.ppdb-online.web.id. 1800    IN      A       139.99.2.142

;; Query time: 0 msec
;; SERVER: 139.99.2.142#53(139.99.2.142)
;; WHEN: Tue Jul 25 13:21:49 EDT 2017
;; MSG SIZE  rcvd: 165

[root@racksx ~]#

What do you think ?

And I am pretty sure it's not NAT.

Offline
***
Re: Name Server Not Working
« Reply #13 on: July 26, 2017, 10:10:49 AM »
already sent you that you server has no open port 53 udp from internet and you can test than only from external computer (NOT your server)
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/