Author Topic: server hostname SSL  (Read 457 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
server hostname SSL
« on: May 14, 2019, 08:04:28 PM »
Hello,

My server hostname is server.somewebsite.com. There is also a working website on my server somewebsite.com. I have created the subdomain of that website with the name "server" and assigned it a SSL certificate. Now whenever I use server.somewebsite.com:2030 I get following SSL Error as it was conflicting with the SSL of somewebsite.com.

"ERROR: None of the common names in the certificate match the name that was entered (server.infinityicon.com). You may receive an error when accessing this site in a web browser."

Now I have removed the "server" subdomain and used sh generate_hostname_ssl so that hostname "server.somewebsite.com" should get the SSL cert but still I am unable to get SSL working for my server's hostname.

Note: For all other websites hosting on my server the SSL is working fine, but its not working when opening CWP control panel.
Kindly suggest me a solution or anything I am missing in the process.

Thanks,
Nauman
« Last Edit: May 14, 2019, 08:21:31 PM by nauman »

Offline
***
Re: server hostname SSL
« Reply #1 on: May 15, 2019, 01:25:09 AM »

Offline
*****
Re: server hostname SSL
« Reply #2 on: May 15, 2019, 02:25:33 AM »
Hello,

There is no need to create a subdomain for the hostname. It is enough that you create an A record in the DNS at server.somewebsite.com and then resave the hostname in Change Hostname menu option. This will generate a new SSL. Don't forget to restart the CWP service: service cwpsrv restart

Hello,

My server hostname is server.somewebsite.com. There is also a working website on my server somewebsite.com. I have created the subdomain of that website with the name "server" and assigned it a SSL certificate. Now whenever I use server.somewebsite.com:2030 I get following SSL Error as it was conflicting with the SSL of somewebsite.com.

"ERROR: None of the common names in the certificate match the name that was entered (server.infinityicon.com). You may receive an error when accessing this site in a web browser."

Now I have removed the "server" subdomain and used sh generate_hostname_ssl so that hostname "server.somewebsite.com" should get the SSL cert but still I am unable to get SSL working for my server's hostname.

Note: For all other websites hosting on my server the SSL is working fine, but its not working when opening CWP control panel.
Kindly suggest me a solution or anything I am missing in the process.

Thanks,
Nauman

Offline
*
Re: server hostname SSL
« Reply #3 on: May 21, 2019, 09:56:19 AM »
Thanks a lot for your replies and I apologize for not contacting you quick due to some problem.
I ll check your provided solutions today and will inform you right away

Offline
**
Re: server hostname SSL
« Reply #4 on: May 22, 2019, 08:55:49 AM »
Hello,

My server hostname is server.somewebsite.com. There is also a working website on my server somewebsite.com. I have created the subdomain of that website with the name "server" and assigned it a SSL certificate. Now whenever I use server.somewebsite.com:2030 I get following SSL Error as it was conflicting with the SSL of somewebsite.com.

"ERROR: None of the common names in the certificate match the name that was entered (server.infinityicon.com). You may receive an error when accessing this site in a web browser."

Now I have removed the "server" subdomain and used sh generate_hostname_ssl so that hostname "server.somewebsite.com" should get the SSL cert but still I am unable to get SSL working for my server's hostname.

Note: For all other websites hosting on my server the SSL is working fine, but its not working when opening CWP control panel.
Kindly suggest me a solution or anything I am missing in the process.

Thanks,
Nauman


Step 6: Let'sEncypt SSL
1. Install Let'sEncypt for Server FQDN and also for Admin/User/Webmail
2. Configure Auto Renewal
3. CWP: Redirect Admin/User/Wemail panel from http to https
4. SSL Inconsistent server configuration [ Error: SSL_ERROR_RX_RECORD_TOO_LONG]
5. CWP: Auto_SSL is not working from both Admin/User Panel [Fixed]

Details:
https://www.awsmonster.com/2017/01/cwp-how-to-configure-let-encrypt-ssl.html
https://www.awsmonster.com/p/cwp-installation-and-configuration_12.html