Author Topic: Rebuilding e-mail  (Read 1142 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Rebuilding e-mail
« on: February 18, 2017, 09:17:41 AM »
Rebuilding E-Mail on Centos 7. How to fix error with "CLAMD"?

Code: [Select]
Loaded plugins: fastestmirror
No Packages marked for removal
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.supportex.net
 * epel: mirror.nl.leaseweb.net
 * extras: mirror.netrouting.net
 * updates: centos.mirror.triple-it.nl
No package clamd available.
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirrors.supportex.net
 * epel: mirror.nl.leaseweb.net
 * extras: mirror.netrouting.net
 * updates: centos.mirror.triple-it.nl
Package opendkim-2.11.0-0.1.el7.x86_64 already installed and latest version
Package libopendkim-2.11.0-0.1.el7.x86_64 already installed and latest version
Package perl-Mail-DKIM-0.39-8.el7.noarch already installed and latest version
Package perl-Mail-SPF-2.8.0-4.el7.noarch already installed and latest version
Package pypolicyd-spf-1.3.2-1.el7.noarch already installed and latest version
No package clamd available.
Nothing to do
Configuring...
Something wrong in Postfix, check log files please...

Offline
*
Re: Rebuilding e-mail
« Reply #1 on: February 25, 2017, 07:47:55 PM »
Clam is not in the CentOS base repos, thus you will have to use an additional such as EPEL.

Offline
*****
Re: Rebuilding e-mail
« Reply #2 on: February 25, 2017, 08:26:05 PM »
try this command :
yum install epel-release
yum clean all

then try to install clamd again

Offline
*
Re: Rebuilding e-mail
« Reply #3 on: February 26, 2017, 02:02:46 AM »
I can confirm this bug & see the same 'Something wrong in postfix' error when I rebuild mail server.

I followed your steps Sandeep & unfortunately still received the same error message (pasted below) when rebuilding the mail server.

Loaded plugins: fastestmirror
No Packages marked for removal
Loaded plugins: fastestmirror
Determining fastest mirrors
 * base: mirror.linuxfix.com
 * epel: mirror.sfo12.us.leaseweb.net
 * extras: mirror.linuxfix.com
 * updates: mirror.linuxfix.com
No package clamd available.
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.linuxfix.com
 * epel: mirror.sfo12.us.leaseweb.net
 * extras: mirror.linuxfix.com
 * updates: mirror.linuxfix.com
Package opendkim-2.11.0-0.1.el7.x86_64 already installed and latest version
Package libopendkim-2.11.0-0.1.el7.x86_64 already installed and latest version
Package perl-Mail-DKIM-0.39-8.el7.noarch already installed and latest version
Package perl-Mail-SPF-2.8.0-4.el7.noarch already installed and latest version
Package pypolicyd-spf-1.3.2-1.el7.noarch already installed and latest version
No package clamd available.
Nothing to do
Configuring...
Something wrong in Postfix, check log files please...


Offline
*
Re: Rebuilding e-mail
« Reply #4 on: February 26, 2017, 04:26:15 PM »
I get the same error when rebuilding mail "Something wrong in Postfix, check log files please..."
but email seems to function without any issues.

Offline
*
Re: Rebuilding e-mail
« Reply #5 on: February 26, 2017, 05:33:18 PM »
please follow this:


The EPEL (Extra Packages for Enterprise Linux) yum repository is an excellent source for additional packages for CentOS. Instead of having to compile applications that aren’t included in CentOS’ built-in repositories from source, EPEL can be used.

# Install/enable the EPEL repo:

yum install epel-release -y



# Install required ClamAV packages

yum install clamav clamd

#Start the clamd service and set it to auto-start

/etc/init.d/clamd on

chkconfig clamd on

/etc/init.d/clamd start

Offline
*
Re: Rebuilding e-mail
« Reply #6 on: February 28, 2017, 01:27:50 PM »
I tried your suggestion but no luck I'm afraid. A rebuild of Postfix gives same message 'Something wrong in postfix'. Reminds me of the Windows 10 roll out bug 'Something went wrong' lol.

[root@mail ~]# yum install epel-release -y
Loaded plugins: fastestmirror
base                                                     | 3.6 kB     00:00
cwp                                                      | 2.9 kB     00:00
extras                                                   | 3.4 kB     00:00
mariadb                                                  | 2.9 kB     00:00
updates                                                  | 3.4 kB     00:00
Loading mirror speeds from cached hostfile
 * base: centos.sonn.com
 * extras: centos.sonn.com
 * updates: centos.sonn.com
Package epel-release-7-9.noarch already installed and latest version
Nothing to do
[root@mail ~]# yum install clamav clamd
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.sonn.com
 * extras: centos.sonn.com
 * updates: centos.sonn.com
No package clamd available.
Nothing to do

Offline
*
Re: Rebuilding e-mail
« Reply #7 on: March 01, 2017, 10:53:10 AM »
I tried your suggestion but no luck I'm afraid. A rebuild of Postfix gives same message 'Something wrong in postfix'. Reminds me of the Windows 10 roll out bug 'Something went wrong' lol.

[root@mail ~]# yum install epel-release -y
Loaded plugins: fastestmirror
base                                                     | 3.6 kB     00:00
cwp                                                      | 2.9 kB     00:00
extras                                                   | 3.4 kB     00:00
mariadb                                                  | 2.9 kB     00:00
updates                                                  | 3.4 kB     00:00
Loading mirror speeds from cached hostfile
 * base: centos.sonn.com
 * extras: centos.sonn.com
 * updates: centos.sonn.com
Package epel-release-7-9.noarch already installed and latest version
Nothing to do
[root@mail ~]# yum install clamav clamd
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.sonn.com
 * extras: centos.sonn.com
 * updates: centos.sonn.com
No package clamd available.
Nothing to do


Open /etc/yum.repos.d/epel.repo and set any instance of ‘enabled=0’ to ‘enabled=1’

then

yum update

and then install again

Offline
*
Re: Rebuilding e-mail
« Reply #8 on: March 01, 2017, 11:16:22 AM »
Thanks for your help, I changed all enabled from 0s to 1' (was 3 of them). I repeated install but received the same output.

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.fileplanet.com
 * epel: mirror.sfo12.us.leaseweb.net
 * epel-debuginfo: mirror.sfo12.us.leaseweb.net
 * epel-source: mirror.sfo12.us.leaseweb.net
 * extras: mirror.fileplanet.com
 * updates: mirror.fileplanet.com
Package clamav-0.99.2-1.el7.x86_64 already installed and latest version
No package clamd available.
Nothing to do

Cross fingers a CWP magically fixes it  :)

Offline
*
Re: Rebuilding e-mail
« Reply #9 on: March 01, 2017, 09:12:58 PM »
its not a cwp error )))

u must be doing smth wrong, if u want i can check it out for you tomorow by logging in to your box
or u can pay for support

or u can do
http://blog.shineservers.com/install-clamav-configure-daily-scanning-centos/
and keep trying

Offline
*
Re: Rebuilding e-mail
« Reply #10 on: March 02, 2017, 03:40:41 PM »
Thanks mate.

I'll keep up the trouble shooting and see if I can't pin point the pain point.

 :)