Author Topic: How to enable the intl extension on CWP ?  (Read 4934 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
How to enable the intl extension on CWP ?
« on: February 20, 2017, 09:19:53 PM »
How to enable the intl extension on CWP ?

i'm trying to --enable-intl in PHP FLAGS and add extension=php_intl.dll in PHP.INI file and restart httpd and nothing happens





Offline
***
Re: How to enable the intl extension on CWP ?
« Reply #1 on: February 21, 2017, 10:07:04 AM »
uncomment these lines,

;extension=php_intl.dll
;extension=php_ldap.dll
;extension=php_curl.dll

not only extension=php_intl.dll. and restart your httpd

Offline
*
Re: How to enable the intl extension on CWP ?
« Reply #2 on: February 24, 2017, 12:02:10 AM »
still error !  :(

Offline
*****
Re: How to enable the intl extension on CWP ?
« Reply #3 on: February 24, 2017, 08:39:11 AM »
still error !  :(

install this
yum install libicu-devel

add php flags
--enable-intl
--with-icu-dir=/usr

Offline
*
Re: How to enable the intl extension on CWP ?
« Reply #4 on: July 31, 2018, 08:30:44 AM »
I have exactly the same problem, I compile with the extension, in phpinfo() if my module (openssl, curl, etc) is there, I enable it (extension=openssl) in php.ini restart apache and it shows me the following error message
Quote
PHP Warning: PHP Startup: Unable to load dynamic library 'curl' (tried: /opt/alt/php72/usr/lib/php/extensions/no-debug-non-zts-20170718/curl (/opt/alt/php72/usr/lib/php/extensions/no-debug-non-zts-20170718/curl: cannot open shared object file: No such file or directory), /opt/alt/php72/usr/lib/php/extensions/no-debug-non-zts-20170718/curl.so (/opt/alt/php72/usr/lib/php/extensions/no-debug-non-zts-20170718/curl.so: cannot open shared object file: No such file or directory))) in Unknown on line 0, referer: https://localhost/index.php

This is repeated with any extension I can undo and looking in that folder of extensions I only see about 8 like imagick, opcache, etc. but none of the ones I undo... so what did I miss because I can't find the file "curl.so" anywhere.