Recent Posts

Pages: 1 ... 8 9 [10]
DNS / Re: How to use 2 domains on one account?
« Last post by overseer on May 21, 2023, 08:11:32 AM »
You can certainly add another add on domain pointing to the same public_html directory. I do that on all my CWP servers. The add-on domains load the same site content as the main domain (in my case, WordPress installs).
DNS / Re: How to use 2 domains on one account?
« Last post by ZothNET on May 21, 2023, 06:25:36 AM »
use addon domain
then add second domain and point it to other directory not public_html

I have been trying to do this but when I go into the little folder and point it to somewhere else besides the public_html of the folder I need it to go to it doesn't go to that site it errors not found.

Example: I have and I want to go to and not change to but stay and show the same website. Basically 2 domains showing the same website.
CentOS-WebPanel Bugs / Re: Cronjob not added from user panel
« Last post by Biswashost on May 21, 2023, 04:12:10 AM »
It's not actually a make-or-break feature for me, as most end users don't know what a cron job is! I prefer it be kept to the admin side with root access. I'm always glad to set up cron jobs if necessary for users who ask me for support -- and that way I can vet the task and make sure it is necessary and runs most efficiently, rather than needlessly often or with resource intensive tasks running at bad times of day. I'm remembering back to my cPanel days when user cronjobs were decidedly NOT a panacea!

Hi, what kind of thinking it is? Just image you have 500+ users & most of them needed this cronjob add/delete for different purpose then what you will do? We have lot's of others task rather than add/delete users cronjob from admin panel. Cronjob a regular hosting feature & most of the client need to use it for different purpose. So, we need to make sure it's working fine from user panel. Good news is that it's already has been fixed with the next update. Thanks, CWP team!
CWPpro version:
CentOS 7

Node Js not available, please contact admin for more information. under user.

after enabling it from admin panel features, Node js tab not showing under domain from user panel.

how to resolve this issue?

Delete the user and create again.... worked for me
CentOS 7 Problems / Re: Fix permissions
« Last post by Dumnezeu on May 20, 2023, 03:21:32 PM »
So i was fixing some permissions on a folder and i typed / instead of ./  :(

Sad short story ;D.

The good thing is that i did this before like any amateur so i called my vps host i asked for safe mode to copy files to my machine which they didn't have  ;D

I went to sleep that night and woke up with mindset to fix the permissions one by one ! I did it in day 3 my vps started working again.

The server security is inexistant, so many bugs specially on mysql.. i know it's impossible to recover the permissions to perfection..

Is there a way to backup --> fresh install --> restore websites ? or reinstall without losing websites ? or any other way  :(

PS: i have access to other cwp machines.

We're in production here :D using free cwp.

Yes you can create a full backup to your website via "Account backups " Save the backup to your local machine and then restore aftere fresh install.
CentOS 7 Problems / Re: Pro no work???
« Last post by Dumnezeu on May 20, 2023, 03:14:35 PM »
I have several purchased CWP Pro licenses, everything is down, it appears to me that I don't have the PRO... change the ips, restart everything, nothing works and the panel shows the subscriptions still paid for almost 1 year... (I updated them about 3 months ago)
hit this command to your server :
Code: [Select]
sh /scripts/update_cwp
CentOS-WebPanel Bugs / Re: User php selector bug
« Last post by Dumnezeu on May 20, 2023, 03:08:20 PM »
I have this error: I build a PHP-FPM in Panel

chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 28505  100 28505    0     0  60137      0 --:--:-- --:--:-- --:--:-- 60010
/usr/local/cwpsrv/htdocs/resources/conf/el8/php-fpm_selector/external_modules/8.1/ line 9: /opt/alt/php-fpm81/usr/bin/phpize: No such file or directory
/usr/local/cwpsrv/htdocs/resources/conf/el8/php-fpm_selector/external_modules/8.1/ line 10: ./configure: No such file or directory
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target 'install'.  Stop.
/usr/local/cwpsrv/htdocs/resources/conf/el8/php-fpm_selector/external_modules/8.1/ line 14: /opt/alt/php-fpm81/usr/bin/php-config: No such file or directory
ERROR: Missing extension file /

Build Completed

sodium devel is installed.

disable secure process and firewall before installing .. see if it's make any difference . and also before installing try yum update
CentOS-WebPanel Bugs / Re: User php selector bug
« Last post by Dumnezeu on May 20, 2023, 03:02:45 PM »
And you reported the bug to the dev team? Or request support to help you with the issue?
i got cwp pro whith no support....
PHP Selector / php selector error 500
« Last post by Dumnezeu on May 20, 2023, 02:48:04 PM »
After clean install cwp pro (twice) i get the same error when trying to use php74 via php selector.

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

I go to server error log and i got this:
Code: [Select]
[Sat May 20 17:27:53.069507 2023] [:error] [pid 14289:tid 140339180427008] [client] SecurityException in Application.cpp:498: Handler not found in configuration
[Sat May 20 17:27:53.069755 2023] [:error] [pid 14289:tid 140339180427008] [client] Caused by KeyNotFoundException in Configuration.cpp:241: Handler "application/x-httpd-php74" not found
[Sat May 20 17:27:53.069789 2023] [core:error] [pid 14289:tid 140339180427008] [client] End of script output before headers: info.php

From this error i understain theat the php version is not installed but it is ... i did installed and reinstalled many times also i did reinstall the whole system just to be sure.
Also if i go to php selector under phpinfo o got all info about the php version.

All other php version work fine.
Updates / Re: Bugs at
« Last post by Freespirits_GR_Host on May 20, 2023, 02:15:24 PM »
One more very important thing to check is the following parameter 

Code: [Select]
Quota Type:
It should be empty if your partition is ext4
or it should be 

Code: [Select]
Quota Type:xfs
if your partition is xfs

In case you messed up with that the use putty or filezzila  and edit the following file

Code: [Select]
Lastly run the following command to have your server rock again :)

Code: [Select]
/scripts/cwp_api account update_diskquota_all

Hope that will save the day to anyone having such problems  8)
Pages: 1 ... 8 9 [10]