Author Topic: SSL does not work on hostname  (Read 3211 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
SSL does not work on hostname
« on: November 01, 2019, 11:30:28 PM »
My domain was published 1 week ago, but to this day does not recognize the domain SSL.

[Check CWP SSL] and [Check WebServers SSL] Is OK.




What to do?

Offline
***
Re: SSL does not work on hostname
« Reply #1 on: November 18, 2019, 09:06:41 PM »
I am having a bit of a problem with this myself...however, without being able to see the browser certificate details, i would say its because your host.domain.com has a "Self Signed" SSL certificate (as does mine)

My understanding is that we obviously need to use a CA registered authority Cert such as Lets Encrypt SSL ...was there a "Checkbox" for Lets Encrypt SSL cert when you performed a Hostname change? (I believe there is supposed to be a checkbox and you need to select it)

I am still trying to figure out how to do this because i have not yet found any reference tutorial on how to do it that actually works with the current version of CWP.

Offline
*
Re: SSL does not work on hostname
« Reply #2 on: December 18, 2019, 04:09:23 PM »
I read that the letsencrypt module was replaced by autossl. 

In cpanel, the letsencrypt plugin has an option to apply a certificate to  "whm/cpanel/webmail services."  I don't know how to do that in CWP.

Offline
*****
Re: SSL does not work on hostname
« Reply #3 on: December 19, 2019, 08:24:38 AM »
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services