Author Topic: Install mod_geoip  (Read 196 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Install mod_geoip
« on: August 15, 2017, 10:32:50 PM »
Hi,

New user of this control panel.

i try to install mod_geoip but i can't.

I enable epel repo, but when i do yum install mod_geoip, i have this error :

Code: [Select]
[root@serveur yum.repos.d]# yum install mod_geoip
Modules complémentaires chargés : fastestmirror, priorities, security
Configuration du processus d'installation
Loading mirror speeds from cached hostfile
 * epel: mirrors.n-ix.net
111 packages excluded due to repository priority protections
Résolution des dépendances
--> Lancement de la transaction de test
---> Package mod_geoip.x86_64 0:1.2.10-1.el6 will be installé
--> Traitement de la dépendance : httpd-mmn = 20051115 pour le paquet : mod_geoip-1.2.10-1.el6.x86_64
--> Traitement de la dépendance : GeoIP(x86-64) pour le paquet : mod_geoip-1.2.10-1.el6.x86_64
--> Traitement de la dépendance : libGeoIP.so.1()(64bit) pour le paquet : mod_geoip-1.2.10-1.el6.x86_64
--> Lancement de la transaction de test
---> Package GeoIP.x86_64 0:1.6.5-1.el6 will be installé
--> Traitement de la dépendance : geoipupdate pour le paquet : GeoIP-1.6.5-1.el6.x86_64
--> Traitement de la dépendance : GeoIP-data pour le paquet : GeoIP-1.6.5-1.el6.x86_64
---> Package httpd.x86_64 0:2.2.15-60.el6.centos.4 will be installé
--> Traitement de la dépendance : httpd-tools = 2.2.15-60.el6.centos.4 pour le paquet : httpd-2.2.15-60.el6.centos.4.x86_64
--> Traitement de la dépendance : apr-util-ldap pour le paquet : httpd-2.2.15-60.el6.centos.4.x86_64
--> Lancement de la transaction de test
---> Package GeoIP-GeoLite-data.noarch 0:2017.07-1.el6 will be installé
--> Traitement de la dépendance : GeoIP-GeoLite-data-extra = 2017.07-1.el6 pour le paquet : GeoIP-GeoLite-data-2017.07-1.el6.noarch
---> Package apr-util-ldap.x86_64 0:1.3.9-3.el6_0.1 will be installé
--> Traitement de la dépendance : apr-util = 1.3.9-3.el6_0.1 pour le paquet : apr-util-ldap-1.3.9-3.el6_0.1.x86_64
---> Package geoipupdate.x86_64 0:2.2.1-2.el6 will be installé
---> Package httpd-tools.x86_64 0:2.2.15-60.el6.centos.4 will be installé
--> Lancement de la transaction de test
---> Package GeoIP-GeoLite-data-extra.noarch 0:2017.07-1.el6 will be installé
---> Package apr-util.i686 0:1.3.9-3.el6_0.1 will be installé
--> Traitement de la dépendance : libuuid.so.1 pour le paquet : apr-util-1.3.9-3.el6_0.1.i686
--> Traitement de la dépendance : libpthread.so.0(GLIBC_2.0) pour le paquet : apr-util-1.3.9-3.el6_0.1.i686
--> Traitement de la dépendance : libpthread.so.0 pour le paquet : apr-util-1.3.9-3.el6_0.1.i686
--> Traitement de la dépendance : libexpat.so.1 pour le paquet : apr-util-1.3.9-3.el6_0.1.i686
--> Traitement de la dépendance : libdb-4.7.so pour le paquet : apr-util-1.3.9-3.el6_0.1.i686
--> Traitement de la dépendance : libcrypt.so.1(GLIBC_2.0) pour le paquet : apr-util-1.3.9-3.el6_0.1.i686
--> Traitement de la dépendance : libcrypt.so.1 pour le paquet : apr-util-1.3.9-3.el6_0.1.i686
--> Traitement de la dépendance : libc.so.6(GLIBC_2.4) pour le paquet : apr-util-1.3.9-3.el6_0.1.i686
--> Traitement de la dépendance : libapr-1.so.0 pour le paquet : apr-util-1.3.9-3.el6_0.1.i686
--> Lancement de la transaction de test
---> Package apr.i686 0:1.3.9-5.el6_2 will be installé
---> Package db4.i686 0:4.7.25-22.el6 will be installé
---> Package expat.i686 0:2.0.1-13.el6_8 will be installé
---> Package glibc.i686 0:2.12-1.209.el6_9.2 will be installé
--> Traitement de la dépendance : libfreebl3.so(NSSRAWHASH_3.12.3) pour le paquet : glibc-2.12-1.209.el6_9.2.i686
--> Traitement de la dépendance : libfreebl3.so pour le paquet : glibc-2.12-1.209.el6_9.2.i686
---> Package libuuid.i686 0:2.17.2-12.28.el6 will be installé
--> Lancement de la transaction de test
---> Package nss-softokn-freebl.i686 0:3.14.3-23.3.el6_8 will be installé
--> Résolution des dépendances terminée
Erreur :  Multilib version problems found. This often means that the root
         cause is something else and multilib version checking is just
         pointing out that there is a problem. Eg.:

           1. You have an upgrade for apr which is missing some
              dependency that another package requires. Yum is trying to
              solve this by installing an older version of apr of the
              different architecture. If you exclude the bad architecture
              yum will tell you what the root cause is (which package
              requires what). You can try redoing the upgrade with
              --exclude apr.otherarch ... this should give you an error
              message showing the root cause of the problem.

           2. You have multiple architectures of apr installed, but
              yum can only see an upgrade for one of those arcitectures.
              If you don't want/need both architectures anymore then you
              can remove the one with the missing update and everything
              will work.

           3. You have duplicate versions of apr installed already.
              You can use "yum check" to get yum show these errors.

         ...you can also use --setopt=protected_multilib=false to remove
         this checking, however this is almost never the correct thing to
         do as something else is very likely to go wrong (often causing
         much more problems).

         Protected multilib versions: apr-1.3.9-5.el6_2.i686 != apr-1.5.2-2.x86_64
Erreur : Protected multilib versions: apr-util-1.3.9-3.el6_0.1.i686 != apr-util-1.5.4-2.x86_64


Is you can help me?

Thanks a lot.
« Last Edit: August 15, 2017, 10:45:40 PM by morgan47 »