Author Topic: WHMCS integration with CWP  (Read 2057 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Re: WHMCS integration with CWP
« Reply #15 on: November 04, 2017, 09:27:50 PM »
I had the module debuggin on.. the request looks correct (sanitised the details):

https://vps2.xxxxxxx.xx:2031/api/?key=cT79nMhEyafZFx93MpXfF&api=account_new&domain=xxxxx.net.xx&username=image&password=xxxxxxx&package=1&email=xxx%40xxxxx.com.au&inode=0&nofile=100000&nproc=40

The response is blank though..in the admin log there is nothing next to the error

Offline
***
Re: WHMCS integration with CWP
« Reply #16 on: November 05, 2017, 05:28:34 AM »
Do you have 127.0.0.1 in /usr/local/cwp/.conf/api_allowed.conf ? Are you behind NAT? If yes put also the NAT IP and your PUBLIC IP in that conf file and try again. Also check if the hash key in /usr/local/cwp/.conf/api_key.conf is the same as the hash key in the server config in your WHMCS.
Current uptime (FreeBSD 8.1-RELEASE-p17):
UNIX is a very simple OS, but you have to be a GENIUS to understand it ...

Offline
*
Re: WHMCS integration with CWP
« Reply #17 on: November 05, 2017, 12:46:42 PM »
I've added it in, but the CWP server and WHMCS are separate boxes. I've added in all the IP's but it isn't behind a NAT. Hash key is the same as I copied the string above from the module log and pasted it into the my browser and it worked aok. Problem is I can't see where it is failing and why. every log is blank.

I am assuming I don't need to enter the CWP username/password, I only need the API Hash key? I've also tried both secure ticked and unticked.

I can't even see on CWP if the attempt to hit the server is even happening.

Offline
***
Re: WHMCS integration with CWP
« Reply #18 on: November 06, 2017, 02:12:58 PM »
Yes, you don`t need username and password. Just the hash. Add the IP of WHMCS and the IP of CWP in the config also. Does your CWP have a domain or it`s by IP ? If it`s by IP it will not work and will not give error. You need hostname/domain for CWP.
Current uptime (FreeBSD 8.1-RELEASE-p17):
UNIX is a very simple OS, but you have to be a GENIUS to understand it ...

Offline
*
Re: WHMCS integration with CWP
« Reply #19 on: November 07, 2017, 06:28:51 AM »
ok I added the CWP IP into the APi config as well but still no joy. My CWP install has it's own domain name which is working.

Offline
***
Re: WHMCS integration with CWP
« Reply #20 on: November 07, 2017, 02:26:58 PM »
Ok, I found WHMCS 7.3.0 nulled and I will test it now to see if it`s working. I also put CentOS 7 with CWP on a KVM. Give me some time for the test.
Current uptime (FreeBSD 8.1-RELEASE-p17):
UNIX is a very simple OS, but you have to be a GENIUS to understand it ...

Offline
*
Re: WHMCS integration with CWP
« Reply #21 on: November 08, 2017, 12:32:10 AM »
no problems.. happy to help test if you need a hand as it isn't a production server at the moment.

Offline
***
Re: WHMCS integration with CWP
« Reply #22 on: November 08, 2017, 03:31:57 PM »
Nah. I have Proxmox server and I make it on LXC or KVM. The problem is that the nulled 7.3.0 is giveing an error on the install. I will try to fix it and to test the module.
Current uptime (FreeBSD 8.1-RELEASE-p17):
UNIX is a very simple OS, but you have to be a GENIUS to understand it ...