Author Topic: WHMCS Module Error  (Read 3261 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
WHMCS Module Error
« on: March 26, 2018, 08:08:33 PM »
Holah

When i try to create a new account on whmcs, i get a

"Order Accept Encountered Problems"

When i check the module debug log i see the following

Code: [Select]
https://server.example.com:2031/api/?key=wMr2MpcukGi0QpvhLMRm6JIZgVDN3LhuA6pGdOucfEH7S&api=account_new&domain=mydomain.co.zw&username=vkkcjcmq&password=ht86t1D6&package=2&email=my%40gmail.com&inode=50000&nofile=60000&nproc=40

Offline
*
Re: WHMCS Module Error
« Reply #1 on: March 26, 2018, 11:38:48 PM »
Try to review and download this new module

http://wiki.centos-webpanel.com/whmcs-module-for-cwp-api

Offline
*
Re: WHMCS Module Error
« Reply #2 on: March 27, 2018, 09:48:42 AM »
Try to review and download this new module

http://wiki.centos-webpanel.com/whmcs-module-for-cwp-api


I followed this tutorial to the last and still get the "Order Accept Encountered Problems error"

How can i check where its wrong ?


I copied the code and ran it on the browser and it gives me the "Allowed IP's not set or you don't have access from IP: xxx.xxx.xxx" even if the ip are set on api manager, is they another place where i go to to enter the IP ? its already allwed on csf
« Last Edit: March 27, 2018, 10:01:45 AM by nuffsaid »

Offline
*

Offline
*
Re: WHMCS Module Error
« Reply #4 on: March 29, 2018, 01:04:13 PM »
stop by here


http://forum.centos-webpanel.com/installation/whmcs-new-module-404/new/?topicseen#new

I followed this guide and still to no avail .

I installed whmcs on the same server and then started getting this error

"{"status":"Error","msj":"unauthorized host","format":"JSON"}"

Offline
*
Re: WHMCS Module Error
« Reply #5 on: March 29, 2018, 01:07:15 PM »
Check the ip that I use in your ad administrator, this IP must be the same one of the server where your WHMCS is located

Offline
*
Re: WHMCS Module Error
« Reply #6 on: June 18, 2018, 08:30:54 PM »
Has anyone got this Module working yet? - no matter what I try I keep getting "Order Accept Encountered Problems"

thanks
Martin...

Offline
*
Re: WHMCS Module Error
« Reply #7 on: June 18, 2018, 08:38:16 PM »
Have you manually tested that the api is responding?

Offline
*
Re: WHMCS Module Error
« Reply #8 on: February 11, 2019, 12:43:58 PM »
stop by here


http://forum.centos-webpanel.com/installation/whmcs-new-module-404/new/?topicseen#new

I followed this guide and still to no avail .

I installed whmcs on the same server and then started getting this error

"{"status":"Error","msj":"unauthorized host","format":"JSON"}"

I have the same problem. When installing WHMCS on the same CWP server with the same IP, I get an unauthorized.
At the API key I inserted the public IP & also whitelisted this IP in the firewall.

Any other CWP server works good.

Will investigate this more. I think it probably follows a (local?) network path instead of going outside & inside again, which will make the server unauthorized.

Offline
*
Re: WHMCS Module Error
« Reply #9 on: February 11, 2019, 02:50:15 PM »
Please try to replace the IP by% in your apikey. If this does not work check that the two IPs of your servers are on a white list

Offline
*
Re: WHMCS Module Error
« Reply #10 on: February 12, 2019, 01:01:03 PM »
Please try to replace the IP by% in your apikey. If this does not work check that the two IPs of your servers are on a white list
Hi thanks for the answer.
When I try this, the user does get created ..... however WHMCS shows the folllowing error:

Service Unavailable
The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later

In the CWP logs I can find the following:
Code: [Select]
[12-Feb-2019 13:51:41] WARNING: [pool cwpsrv] child 930 said into stderr: "Redirecting to /bin/systemctl status lfd.service"
[12-Feb-2019 13:55:05] WARNING: [pool cwpsrv] child 930 said into stderr: "New password: "
[12-Feb-2019 13:55:06] WARNING: [pool cwpsrv] child 930 said into stderr: "Retype new password: "
[12-Feb-2019 13:55:06] WARNING: [pool cwpsrv] child 930 said into stderr: "ERROR 1141 (42000) at line 1: There is no such grant defined for user 'klpstowo' on host 'localhost'"

Right now I am trying to find out where this is going wrong.

Offline
*
Re: WHMCS Module Error
« Reply #11 on: February 27, 2019, 11:05:24 AM »
Was this error solved?

My API settings show the URL to the API as my IPv4. I am still getting the error.