Author Topic: Php 7 install problem - CWP Php Selector  (Read 1040 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Php 7 install problem - CWP Php Selector
« on: February 19, 2017, 12:09:28 PM »
Hello, I have a problem with Php selector and I can't solve it.

When I start to compiler php 7, I got this logs and error.

  7900K .......... .......... .......... .......... .......... 97% 36.9M 0s
  7950K .......... .......... .......... .......... .......... 97% 51.0M 0s
  8000K .......... .......... .......... .......... .......... 98% 50.5M 0s
  8050K .......... .......... .......... .......... .......... 99% 49.8M 0s
  8100K .......... .......... .......... .......... .......... 99%  823K 0s
  8150K .......... ....                                       100% 28012G=2.5s

2017-02-19 11:48:23 (3.18 MB/s) - `ioncube_loaders_lin_x86.tar.gz' saved [836063                                                                                        9/8360639]

Initialized empty Git repository in /tmp/php-build/php-src/.git/
Loaded plugins: fastestmirror
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: ftp.nluug.nl
 * extras: ftp.nluug.nl
 * ius: mirror.amsiohosting.net
 * rpmforge: repoforge.mirror.wearetriple.com
 * updates: ftp.nluug.nl
Package gcc-4.4.7-17.el6.i686 already installed and latest version
Package gcc-c++-4.4.7-17.el6.i686 already installed and latest version
Package 1:make-3.81-23.el6.i686 already installed and latest version
Package openssl-devel-1.0.1e-48.el6_8.3.i686 already installed and latest versio                                                                                        n
Package autoconf-2.63-5.1.el6.noarch already installed and latest version
Package bison-2.4.1-5.el6.i686 already installed and latest version
Package git-1.7.1-4.el6_7.1.i686 already installed and latest version
No package checkinstall available.
Package httpd-devel-2.2.15-56.el6.centos.3.i686 already installed and latest ver                                                                                        sion
Package libxml2-devel-2.7.6-21.el6_8.1.i686 already installed and latest version
Package libcurl-devel-7.19.7-52.el6.i686 already installed and latest version
Package libjpeg-turbo-devel-1.2.1-3.el6_5.i686 already installed and latest vers                                                                                        ion
Package 2:libpng-devel-1.2.49-2.el6_7.i686 already installed and latest version
Package libXpm-devel-3.5.10-2.el6.i686 already installed and latest version
Package mysql-devel-5.1.73-8.el6_8.i686 is obsoleted by MariaDB-devel-10.1.21-1.                                                                                        el6.i686 which is already installed
Package postgresql-libs-8.4.20-6.el6.i686 already installed and latest version
Package libicu-devel-4.2.1-14.el6.i686 already installed and latest version
Package freetype-devel-2.3.11-17.el6.i686 already installed and latest version
Package libxslt-devel-1.1.26-2.el6_3.1.i686 already installed and latest version
Package bzip2-devel-1.0.5-7.el6_0.i686 already installed and latest version
Package gmp-devel-4.3.1-10.el6.i686 already installed and latest version
Package matching libmcrypt-devel-2.5.7-1.2.el6.rf.i686 already installed. Checki                                                                                        ng for update.
Package 12:aspell-devel-0.60.6-12.el6.i686 already installed and latest version
Package recode-devel-3.6-28.1.el6.i686 already installed and latest version
Nothing to do
buildconf: checking installation...
buildconf: autoconf version 2.63 (ok)
rebuilding aclocal.m4
rebuilding configure
configure.ac:276: error: Autoconf version 2.64 or higher is required
build/ax_check_compile_flag.m4:60: AX_CHECK_COMPILE_FLAG is expanded from...
autom4te: /usr/bin/m4 failed with exit status: 63
rebuilding main/php_config.h.in
configure.ac:276: error: Autoconf version 2.64 or higher is required
build/ax_check_compile_flag.m4:60: AX_CHECK_COMPILE_FLAG is expanded from...
autom4te: /usr/bin/m4 failed with exit status: 63
autoheader: '/usr/bin/autom4te' failed with exit status: 63
/usr/local/cwp/.conf/php_conf/php7.conf: line 1: ./configure: No such file or di                                                                                        rectory
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target `install'.  Stop.
Stopping httpd: [  OK  ]
Starting httpd: [  OK  ]

Build Completed
###################



After this things, php 7 is still red.

configure.ac:276: error: Autoconf version 2.64 or higher is required
build/ax_check_compile_flag.m4:60: AX_CHECK_COMPILE_FLAG is expanded from...
autom4te: /usr/bin/m4 failed with exit status: 63
autoheader: '/usr/bin/autom4te' failed with exit status: 63
/usr/local/cwp/.conf/php_conf/php7.conf: line 1: ./configure: No such file or di                                                                                        rectory
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target `install'.  Stop.

So problem is here so what can I do? Do you have any idea?

Thx !  :)



Offline
**
Re: Php 7 install problem - CWP Php Selector
« Reply #1 on: March 29, 2017, 08:09:23 PM »
confirmed problem still there..

Offline
*
Re: Php 7 install problem - CWP Php Selector
« Reply #2 on: March 30, 2017, 04:58:09 AM »
which version of centos 7 exactly as there are 7.0, 7.1 and 7x (development)?
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: Php 7 install problem - CWP Php Selector
« Reply #3 on: April 21, 2017, 03:22:53 PM »