Author Topic: PHP-FPM Not Working (503 Service Unavailable)  (Read 1725 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
PHP-FPM Not Working (503 Service Unavailable)
« on: July 04, 2019, 09:58:10 AM »
Hello

When I check "Force Apache to use PHP-FPM Selector, this will disable PHP Selector 2 and PHP Version Switcher." and rebuild configuration the  result on website show 503 Service Unavailable

How to fix it?

Thank you

Offline
*****
Re: PHP-FPM Not Working (503 Service Unavailable)
« Reply #1 on: July 04, 2019, 11:17:58 PM »
Is CWPpro running?

Please check the logs of your website from /usr/local/apache/domlogs/

Offline
*
Re: PHP-FPM Not Working (503 Service Unavailable)
« Reply #2 on: July 05, 2019, 02:28:42 PM »
This log from website

Code: [Select]
[Fri Jul 05 09:27:47.128872 2019] [proxy:error] [pid 1729:tid 140330934396672] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /opt/alt/php-fpm73/usr/var/sockets/nontongr.sock (*) failed
[Fri Jul 05 09:27:47.128911 2019] [proxy_fcgi:error] [pid 1729:tid 140330934396672] [client 40.77.167.17:42758] AH01079: failed to make connection to backend: httpd-UDS

Offline
*
Re: PHP-FPM Not Working (503 Service Unavailable)
« Reply #3 on: July 05, 2019, 08:50:45 PM »
webserversw/fpm build logs location
/var/log/cwp/webservers.log
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: PHP-FPM Not Working (503 Service Unavailable)
« Reply #4 on: July 08, 2019, 08:05:26 AM »
webserversw/fpm build logs location
/var/log/cwp/webservers.log
Code: [Select]
2019-07-08 08:07:50 mydomain.net Running Nginx/Apache/PHP-FPM
2019-07-08 08:07:50 mydomain.net Delete all configuration for domain
2019-07-08 08:07:50 mydomain.net Nginx: SUCCESS conf enabled
2019-07-08 08:07:50 mydomain.net Nginx SSL: SUCCESS conf enabled template: php-fpm/default
2019-07-08 08:07:50 mydomain.net Apache: SUCCESS conf enabled
2019-07-08 08:07:50 mydomain.net Apache SSL: SUCCESS conf enabled template: php-fpm/default
2019-07-08 08:07:50 mydomain PHP-FPM php-fpm73: ERROR failed at quota or security limits
2019-07-08 08:07:50 mydomain PHP-FPM php-fpm73: INFO conf added for nobody user
2019-07-08 08:07:50 PHP-FPM php-fpm73: reload

Still not working until now, I run CWP PRO but I did not find a satisfactory answer to this

Offline
*
Re: PHP-FPM Not Working (503 Service Unavailable)
« Reply #5 on: July 18, 2019, 12:39:09 PM »
Security limits - you can have limit 0 proces, or  if you use multiple servers you can have missconfigured users for nginx, varnish, apache and ports. They not listen each other at default and  ports for nginx and apache are the same, and another problem is that default socket is not configuret per user - you get only 1 for nobody - if you want normal then you need maually add it.
But that is not all - it  not resolve problem with php when choose php-fpm - it still not work. It let you run only html. I have the same problem:
https://forum.centos-webpanel.com/apache/php-not-work-at-nginx-varnish-apache-(php-fpm)/
But i not find reason. I supposed that php-fpm not listen vhost and try another location - but why idk, and where change it also I don't discover.
« Last Edit: July 18, 2019, 01:12:52 PM by skyref »

Offline
*
Re: PHP-FPM Not Working (503 Service Unavailable)
« Reply #6 on: October 07, 2019, 10:49:02 AM »
i have same error

Offline
*
Re: PHP-FPM Not Working (503 Service Unavailable)
« Reply #7 on: October 07, 2019, 11:30:36 AM »
you need to have cwppro for php-fpm selector
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: PHP-FPM Not Working (503 Service Unavailable)
« Reply #8 on: October 24, 2019, 11:10:18 PM »
I have the same problem.
Some accounts produces 503 error some not.

Problem completely solved after I add more "Process limit" and "Open files" params to account (with "Update Webservers" option).
See /var/log/cwp/webservers.log during that operation for details...