Author Topic: FFmpeg installed but not in phpinfo  (Read 17503 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
FFmpeg installed but not in phpinfo
« on: August 16, 2016, 03:27:49 PM »
Hi,

I've installed the FFmpeg extension via the CWP admin panel, however I'm not seeing it in my phpinfo().  When I check Admin Panel > PHP Settings > FFMPEG Installer I see:

FFMPEG already installed! File Path: /usr/bin/ffmpeg

and sure enough if I type ffmpeg at the command line I get a response:

Code: [Select]
# ffmpeg
FFmpeg version 0.6.5, Copyright (c) 2000-2010 the FFmpeg developers
  built on Jan 29 2012 17:52:15 with gcc 4.4.5 20110214 (Red Hat 4.4.5-6)
  configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --mandir=/usr/share/man --incdir=/usr/include --disable-avisynth --extra-cflags='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fPIC' --enable-avfilter --enable-avfilter-lavf --enable-libdc1394 --enable-libdirac --enable-libfaac --enable-libfaad --enable-libfaadbin --enable-libgsm --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libx264 --enable-gpl --enable-nonfree --enable-postproc --enable-pthreads --enable-shared --enable-swscale --enable-vdpau --enable-version3 --enable-x11grab
  libavutil     50.15. 1 / 50.15. 1
  libavcodec    52.72. 2 / 52.72. 2
  libavformat   52.64. 2 / 52.64. 2
  libavdevice   52. 2. 0 / 52. 2. 0
  libavfilter    1.19. 0 /  1.19. 0
  libswscale     0.11. 0 /  0.11. 0
  libpostproc   51. 2. 0 / 51. 2. 0
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'

However it does not appear in my phpinfo() file.  Has anyone any idea how I would fix this?

Thanks

Offline
*****
Re: FFmpeg installed but not in phpinfo
« Reply #1 on: August 23, 2016, 10:08:07 AM »
Hi, if you need ffmpeg as PHP module, you have to compile it yourself from source.