Author Topic: PHP Selector  (Read 30887 times)

0 Members and 1 Guest are viewing this topic.

Offline
**
Re: PHP Selector
« Reply #15 on: March 06, 2016, 04:54:44 PM »
used CWP build in compilation function

Offline
*
Re: PHP Selector
« Reply #16 on: August 03, 2016, 04:10:16 PM »


What result do you get if you use?:

AddHandler application/x-httpd-php7 .php

That is working for me.

I think the wiki should be updated though.

Php 7 is not there yet ;)

See http://wiki.centos-webpanel.com/php-selector

Code: [Select]
AddHandler application/x-httpd-php7 .phpjust add it

Offline
*
Re: PHP Selector
« Reply #17 on: August 25, 2016, 03:50:50 PM »
how do i load php module?
i try to install imagemagic, it only apply to default php 54 that used by CWP server

Offline
*
Re: PHP Selector
« Reply #18 on: September 04, 2016, 04:32:17 PM »
Please tell me where in CWP defined url of php destro for particular php-selector?
Today, I've installed php-5.6 in new php-selector, and CWP downloaded and installed php-5.6.14,
but it's already outdated: php.net offers php-5.6.23. And my soft wants php >= 5.6.19.
What CWP's config should I change in order to download and install the version of php which I need?
Thank you!

Offline
*
Re: PHP Selector
« Reply #19 on: September 18, 2016, 11:38:38 AM »
Error PHP Selector

if the .htaccess is installed we get the error message, it is deleted everything goes and I can call the phpinfo.php.

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, vxxxxxx@mail.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


the logs dosent exent
« Last Edit: September 18, 2016, 12:19:01 PM by Com-QuadTech »

Offline
*
Re: PHP Selector
« Reply #20 on: May 12, 2017, 04:47:55 PM »
Hello can someone tell me how I get 4.5 on it and not 4.5.45 ??
Since the one script probably only under 4.5 goes right

I thank you ever for an answer

Offline
*
Re: PHP Selector
« Reply #21 on: May 17, 2017, 08:16:31 AM »
Problem  :-[
İ install all php versions and my server working no problem. But when i want to use any one version php , i create a .htaccess file and type
AddHandler application/x-httpd-php56 .php
in .htaccess file save and restart copmlete VPS or apache server after try my site my site give  to me my index.php to save  my computer.?
how i am solve this problem?
Same problem on my CWP. I try with AddHandler application/x-httpd-php56 .php in htaccess and all i get is file download after web site visit.

Offline
*
Re: PHP Selector
« Reply #22 on: May 17, 2017, 08:24:25 AM »
check that you have installed required php versions in cwp.admin php selector
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: PHP Selector
« Reply #23 on: May 18, 2017, 06:11:32 AM »
Yes, i have 5.6 installed... Is it safe to change PHP to 5.6 on CWP basis?

Offline
**
Re: PHP Selector
« Reply #24 on: September 30, 2017, 10:50:13 AM »
I can't compile PHP 5.2 version.
I get error like this:

/tmp/php-build/php-5.2.17/ext/dom/node.c: In function 'dom_canonicalization':
/tmp/php-build/php-5.2.17/ext/dom/node.c:1953:21: error: dereferencing pointer to incomplete type
    ret = buf->buffer->use;
                     ^
In file included from /tmp/php-build/php-5.2.17/main/php.h:38:0,
                 from /tmp/php-build/php-5.2.17/ext/dom/node.c:26:
/tmp/php-build/php-5.2.17/ext/dom/node.c:1955:40: error: dereferencing pointer to incomplete type
     RETVAL_STRINGL((char *) buf->buffer->content, ret, 1);
                                        ^
/tmp/php-build/php-5.2.17/Zend/zend_API.h:472:14: note: in definition of macro 'ZVAL_STRINGL'
   char *__s=(s); int __l=l;  \
              ^
/tmp/php-build/php-5.2.17/ext/dom/node.c:1955:5: note: in expansion of macro 'RETVAL_STRINGL'
     RETVAL_STRINGL((char *) buf->buffer->content, ret, 1);
     ^
make: *** [ext/dom/node.lo] Error 1
make: *** Waiting for unfinished jobs....
/bin/sh /tmp/php-build/php-5.2.17/libtool --silent --preserve-dup-deps --mode=compile gcc  -Iext/dom/ -I/tmp/php-build/php-5.2.17/ext/dom/ -DPHP_ATOM_INC -I/tmp/php-build/php-5.2.17/include -I/tmp/php-build/php-5.2.17/main -I/tmp/php-build/php-5.2.17 -I/tmp/php-build/php-5.2.17/ext/date/lib -I/usr/include/libxml2 -I/usr/include/freetype2 -I/usr/include/imap -I/tmp/php-build/php-5.2.17/ext/mbstring/oniguruma -I/tmp/php-build/php-5.2.17/ext/mbstring/libmbfl -I/tmp/php-build/php-5.2.17/ext/mbstring/libmbfl/mbfl -I/usr/include/mysql -I/tmp/php-build/php-5.2.17/TSRM -I/tmp/php-build/php-5.2.17/Zend    -I/usr/include -g -O2  -c /tmp/php-build/php-5.2.17/ext/dom/node.c -o ext/dom/node.lo
/tmp/php-build/php-5.2.17/ext/dom/node.c: In function 'dom_canonicalization':
/tmp/php-build/php-5.2.17/ext/dom/node.c:1953:21: error: dereferencing pointer to incomplete type
    ret = buf->buffer->use;
                     ^
In file included from /tmp/php-build/php-5.2.17/main/php.h:38:0,
                 from /tmp/php-build/php-5.2.17/ext/dom/node.c:26:
/tmp/php-build/php-5.2.17/ext/dom/node.c:1955:40: error: dereferencing pointer to incomplete type
     RETVAL_STRINGL((char *) buf->buffer->content, ret, 1);
                                        ^
/tmp/php-build/php-5.2.17/Zend/zend_API.h:472:14: note: in definition of macro 'ZVAL_STRINGL'
   char *__s=(s); int __l=l;  \
              ^
/tmp/php-build/php-5.2.17/ext/dom/node.c:1955:5: note: in expansion of macro 'RETVAL_STRINGL'
     RETVAL_STRINGL((char *) buf->buffer->content, ret, 1);
     ^
make: *** [ext/dom/node.lo] Error 1
Redirecting to /bin/systemctl restart httpd.service