Author Topic: PHP Switcher not Switching?  (Read 1291 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
PHP Switcher not Switching?
« on: December 11, 2017, 12:31:07 AM »
Hello.
i have latest CWP installed on Centos linux VPS .. need to have PHP 7 for my magento .. i used the switcher , gone through the compile and still i see same old php version on the dash ..

i found this control panel exhausting..maybe some one can recommend a panel that i can install on centos vps that is free and actually works ?

Offline
*
Re: PHP Selector not Switching?
« Reply #1 on: December 11, 2017, 06:04:13 PM »
There seems to be problem with switching to version 7.x .. i managed to switch to . 5.6.31 from 5.6.30 .. and that worked. looked at the process in SSH while was downloading and installing ..but with 7.x is not the same , i can see stuff being processed but at the end messaged says nothing to do , install made . and nothing really happens.

if anyone knows how to switch to 7.x or figure what seems to be the problem , let me know. thanks.

site admin, could you please move this topic to the right location ( PHP SELECTOR ). thanks.
« Last Edit: December 11, 2017, 06:06:25 PM by tonysar »

Offline
***
Re: PHP Switcher not Switching?
« Reply #2 on: January 12, 2018, 04:16:40 AM »
Have you tried to Install Dependencies?
/admin/index.php?module=php_selector


Offline
*
Re: PHP Switcher not Switching?
« Reply #3 on: January 13, 2018, 11:29:42 PM »
Are you referring to the PHP Switcher(This is the main PHP version switcher) or PHP Selector(adding php version for use with domains)? If your talking about the Selector try changing the flag --with-pdo-mysql=/usr with --with-pdo-mysql=mysqlnd It should compile then.

If your talking about the Switcher, you will have to change /usr/local/cwpsrv/htdocs/resources/conf/php_switcher/7.1.ini (replace the 7.1 with what ever version you want) find the section pdo-mysql=/usr and change to pdo-mysql=mysqlnd
« Last Edit: January 14, 2018, 12:00:15 AM by tbarlet »
4 Xeon quad core processors - 4TB HDD - 64 GB memory - Centos 7 on a fiber 1GB connection