Author Topic: PHP Version Switcher, CWP PHP Selector - CWP, user, root...  (Read 1126 times)

0 Members and 1 Guest are viewing this topic.

Offline
***
Hi,

I installed the CWP with Centos 7 and I have the following questions:
1. In the PHP info I see the following line: „Warning: file_get_contents(http://87.246.45.29/phpinfo.php): failed to open stream: Connection refused in /usr/local/cwpsrv/htdocs/resources/admin/modules/php_info.php on line 0”. Does this problem and how can I fix it ??!
2. In the same menu, I see that my PHP version for pan is 5.6.30, do this version leave or change with PHP Version Switcher v2 to higher and which version of this new higher version? !?
2a. Which modules should I check for installing when comparing to a new version with PHP Version Switcher v2 ...?!?
3. Which version of PHP is appropriate to use for CWP and what version of the user?
4. At this stage I did not create a user, but I'm still working as a root ... if I create a user, which version will take on the PHP?!? I know I can use CWP PHP Selector to switch to the versions, but my question is what version of PHP will have a touch without using CWP PHP Selecter ???
5. If I have already made a user and entered with name and password, how can I use CWP PHP Selector for the user?
6. Can I make a version with CWP PHP Selector to use a higher version for a user, folder, or file?
7. Can I have one version with CWP PHP Selector set to use a lower value for a user, folder, or file?
8. In “CWP PHP Selector:
Before installing PHP versions, you need to install required dependencies.”
 Please provide more info on " dependencies "??

Thanks in advance!

BR
Venty

Offline
***
Re: PHP Version Switcher, CWP PHP Selector - CWP, user, root...
« Reply #1 on: June 04, 2018, 10:48:54 AM »
Pls... :)

Offline
***
Re: PHP Version Switcher, CWP PHP Selector - CWP, user, root...
« Reply #2 on: June 08, 2018, 09:03:13 AM »
Sorry I have to ask did you do a simple search before you raise a question, anyway I will try to answer your questions as you are new here.
1. Check permission of this file : /usr/local/cwpsrv/htdocs/resources/admin/modules/php_info.php, it should exist and 644 permission
2. This version 5.6.30 will be changed to the one that you decided to switch
2a. Leave it default , you don't need to change anything unless your PHP app needs additional function (example : imap, mongodb ...)
3. This version 5.6.30 is a main version and described clearly in CWP dashboard, all users have the same php version (unless you install multiple php version)
4. v5.6.30
5. php.ini
6. Yes , but not recommend because you are very new to it
7. Yes , but not recommend because you are very new to it
8. Yes, install dependencies if your need to use multiple php versions. Dependencies are additional required libraries


Offline
***
Re: PHP Version Switcher, CWP PHP Selector - CWP, user, root...
« Reply #3 on: June 08, 2018, 01:45:56 PM »
Hi,

thank you warmly for the answer, but to clarify on question 8:

it is said:

Before installing PHP versions, you need to install required dependencies. "

The question is  - "dependencies" for a specific version of the PHP....?!?, Is there a specific "dependencies" for a specific version of the PHP and how to find out which version they are?

Thanks in advance!

BR
Venty

Offline
***
Re: PHP Version Switcher, CWP PHP Selector - CWP, user, root...
« Reply #4 on: June 09, 2018, 07:04:04 AM »
"dependencies" is needed for the process to rebuild PHP regardless any PHP version. It is the system operation, similar to windows .dll, C+ libraries