Author Topic: Postfix error 454 4.7.1 - Dont recive email  (Read 349 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Postfix error 454 4.7.1 - Dont recive email
« on: April 05, 2018, 09:00:22 AM »
Hello guys.

Sorry my bass, I'm a Portuguese speaker.

I have a problem with postfix. Emails are usually sent, but I do not receive any.

main.cf
Code: [Select]
# postfix config file

# uncomment for debugging if needed
#soft_bounce=yes

# postfix main
mail_owner = postfix
setgid_group = postdrop
delay_warning_time = 4

# postfix paths
html_directory = no
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
queue_directory = /var/spool/postfix
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
manpage_directory = /usr/share/man

# network settings
inet_interfaces = all
mydomain = haldlaweb.com.br
myhostname = dvsrv02.halldaweb.com.br
mynetworks = $config_directory/mynetworks
mydestination = $myhostname, localhost.$mydomain, localhost
relay_domains = proxy:mysql:/etc/postfix/mysql-relay_domains_maps.cf

# mail delivery
recipient_delimiter = +

# mappings
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
transport_maps = hash:/etc/postfix/transport
#local_recipient_maps =

# virtual setup
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_alias_maps.cf, regexp:/etc/postfix/virtual_regexp
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains_maps.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_maps.cf
virtual_minimum_uid = 101
virtual_uid_maps = static:101
virtual_gid_maps = static:12
virtual_transport = dovecot
dovecot_destination_recipient_limit = 1

# debugging
debug_peer_level = 2
debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5

# authentication
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain = $myhostname
broken_sasl_auth_clients = yes
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth

# tls config
smtp_use_tls = yes
smtpd_use_tls = yes
smtpd_tls_security_level = may
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
smtp_tls_session_cache_database = btree:$data_directory/smtp_tls_session_cache
# Change mail.example.com.* to your host name
smtpd_tls_key_file = /etc/pki/tls/private/dvsrv02.halldaweb.com.br.key
smtpd_tls_cert_file = /etc/pki/tls/certs/dvsrv02.halldaweb.com.br.crt
smtpd_tls_CAfile = /etc/pki/tls/certs/ca-bundle.crt
smtp_tls_CAfile = /etc/pki/tls/certs/ca-bundle.crt

# rules restrictions
smtpd_client_restrictions =
smtpd_helo_restrictions =
smtpd_sender_restrictions =
smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, check_client_access hash:/etc/postfix/sender_whitelist, check_client_access hash:/etc/postfix/sender_blacklist, reject_unauth_destination, reject_non_fqdn_sender, reject_non_fqdn_recipient, reject_unknown_recipient_domain, reject_rbl_client zen.spamhaus.org, reject_rbl_client bl.spamcop.net

smtpd_helo_required = yes
unknown_local_recipient_reject_code = 550
disable_vrfy_command = yes
smtpd_data_restrictions = reject_unauth_pipelining

# Other options
# email size limit ~20Meg
message_size_limit = 204800000
mailbox_size_limit = 2048000000

# Limit 500 emails per hour per email address
anvil_rate_time_unit = 3600s
smtpd_client_message_rate_limit = 500

# Vacation Scripts
vacation_destination_recipient_limit = 1
recipient_bcc_maps = proxy:mysql:/etc/postfix/mysql-virtual_vacation.cf
smtpd_milters = inet:127.0.0.1:8891
non_smtpd_milters = $smtpd_milters
milter_default_action = accept
milter_protocol = 2


Log:

Code: [Select]
Apr  5 05:58:51 dvsrv02 postfix/smtpd[60536]: connect from mail-io0-f194.google.com[209.85.223.194]
Apr  5 05:58:52 dvsrv02 postfix/smtpd[60536]: Anonymous TLS connection established from mail-io0-f194.google.com[209.85.223.194]: TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)
Apr  5 05:58:52 dvsrv02 postfix/smtpd[60536]: NOQUEUE: reject: RCPT from mail-io0-f194.google.com[209.85.223.194]: 454 4.7.1 <contato@anderson.cf>: Relay access denied; from=<anderson@halldaweb.com.br> to=<contato@anderson.cf> proto=ESMTP helo=<mail-io0-f194.google.com>
Apr  5 05:58:52 dvsrv02 postfix/smtpd[60536]: disconnect from mail-io0-f194.google.com[209.85.223.194]
 

I've tried everything, anyone have any tips?

Offline
*
Re: Postfix error 454 4.7.1 - Dont recive email
« Reply #1 on: April 05, 2018, 09:01:46 AM »
P.S: anderson@halldaweb.com.br - google apps
contato@anderson.cf - roundcube - cwp

Offline
***
Re: Postfix error 454 4.7.1 - Dont recive email
« Reply #2 on: April 08, 2018, 03:37:38 PM »
The most problem like yours can be solved by rebuilding mail server.

You can try change hostname (even with same as before), the server will recreate certificate.
then rebuilding mail server.


For me, as I heavily modified email server, rebuilding mail server is "panic button"