Author Topic: AutoSSL Unable to select correct IP  (Read 404 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
AutoSSL Unable to select correct IP
« on: August 27, 2018, 06:04:40 AM »
Hi,

Installed 6 autossl certs for domains without issue but now for some reason I am unable to select the main shared IP from the drop down list. My VPS has 3 ips and only the 2 additional ips are listed.

Are there limits are the number of free certs that can be issued to an ip or is something wrong.

Offline
****
Re: AutoSSL Unable to select correct IP
« Reply #1 on: August 27, 2018, 09:13:46 AM »
choose any ip and click install.

Offline
*
Re: AutoSSL Unable to select correct IP
« Reply #2 on: August 27, 2018, 05:18:02 PM »
Unfortunately something's not right. Whilst Let's Encrypt issues the cert no problem when I try to visit the website via Https it serves the default Https site. This only seems to have started happening since the main shared IP disappeared from the IP drop down list. Surely something's not right for it not to appear as an option?

Offline
****
Re: AutoSSL Unable to select correct IP
« Reply #3 on: August 28, 2018, 05:38:07 AM »
Check if  ip is good in this file
Code: [Select]
cat /usr/local/apache/conf.d/vhosts-ssl.conf

Offline
*
Re: AutoSSL Unable to select correct IP
« Reply #4 on: September 03, 2018, 08:06:21 AM »
OK. The IP selected on the AutoSSL screen is the one being set in the vhost-ssl file. But the DNS is pointing to the primary IP. Changed the vhosts-ssl template ip field to * wild card so it will load for any IP.

However, I would still say this is a bit of a work around and it should be showing all IP's on the AUTOSSL drop down options.

Offline
*
Re: AutoSSL Unable to select correct IP
« Reply #5 on: September 03, 2018, 10:00:11 AM »
Please make sure you have the latest version of CWP, since this problem was solved

Offline
****
Re: AutoSSL Unable to select correct IP
« Reply #6 on: September 03, 2018, 11:23:23 AM »
Well my question is why does install autossl even ask for ip?