Author Topic: Getting error when requesting SSL cert  (Read 235 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Getting error when requesting SSL cert
« on: August 26, 2017, 02:00:44 AM »
Code: [Select]
AutoSSL Issue Failed![Fri Aug 25 18:50:57 PDT 2017] Single domain='********.com'
[Fri Aug 25 18:50:57 PDT 2017] Getting domain auth token for each domain
[Fri Aug 25 18:50:57 PDT 2017] Getting webroot for domain='********.com'
[Fri Aug 25 18:50:57 PDT 2017] Getting new-authz for domain='********.com'
[Fri Aug 25 18:50:59 PDT 2017] The new-authz request is ok.
[Fri Aug 25 18:50:59 PDT 2017] Verifying:********.com
[Fri Aug 25 18:51:02 PDT 2017] scriptophobia.com:Verify error:Fetching https://%25domain_name/.well-known/acme-challenge/ppUJQh7OK3dBKL0AuoH9pMaGqwhaKkBDCZZvdm9Ajb0: Error getting validation data
[Fri Aug 25 18:51:02 PDT 2017] Please check log file for more details: /root/.acme.sh/acme.sh.log
AutoSSL Issue Failed![Fri Aug 25 18:51:03 PDT 2017] Single domain='********.com'
[Fri Aug 25 18:51:03 PDT 2017] Getting domain auth token for each domain
[Fri Aug 25 18:51:03 PDT 2017] Getting webroot for domain='********.com'
[Fri Aug 25 18:51:03 PDT 2017] Getting new-authz for domain='********.com'
[Fri Aug 25 18:51:05 PDT 2017] The new-authz request is ok.
[Fri Aug 25 18:51:05 PDT 2017] Verifying:********.com
[Fri Aug 25 18:51:09 PDT 2017] ********.com:Verify error:Fetching https://%25domain_name/.well-known/acme-challenge/HzLmq5WubNNwCv8JaeibUmrSwsXSxU4nyL3HFtTxlHU: Error getting validation data
[Fri Aug 25 18:51:09 PDT 2017] Please check log file for more details: /root/.acme.sh/acme.sh.log

Already have several certs for other domains so I know it is working. Any ideas?

Offline
*
Re: Getting error when requesting SSL cert
« Reply #1 on: August 26, 2017, 08:45:16 AM »
try checking domain redirection (probably .htaccess file) as it redirects to invalid location

http://scriptophobia.com redirects to https://%25domain_name/
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

Offline
*
Re: Getting error when requesting SSL cert
« Reply #2 on: August 26, 2017, 01:31:00 PM »
Thanks for the direction. Unfortunately, there are no redirects in the .htaccess file.

The redirect showing is just the script I think, that says sub the domain name of the %25domain_name for I remember seeing it on the other sites on the host.

Offline
*
Re: Getting error when requesting SSL cert
« Reply #3 on: August 28, 2017, 10:18:11 PM »
you redirection is not good, so you need to resolve that as you can't open that domain and that means you can't validate ssl then.
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

Offline
*
Re: Getting error when requesting SSL cert
« Reply #4 on: August 29, 2017, 12:49:05 AM »
Trying to find the issue with the redirect but nothing:

Code: [Select]
# vhost_start scriptophobia.com
<VirtualHost 23.111.69.102:80>
ServerName scriptophobia.com
# This line was added for HTTPS load
#RedirectMatch permanent ^(.*)$ https://%domain_name$1
# End of added line
ServerAlias www.scriptophobia.com
ServerAdmin ***@gmail.com
DocumentRoot "/home/***/public_html/scriptophobia"
ScriptAlias /cgi-bin/ /home/***/public_html/scriptophobia/cgi-bin/
#
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/***/scriptophobia.com/*.conf

<IfModule mod_suexec.c>
        SuexecUserGroup daowenpu daowenpu
</IfModule>

<IfModule mod_suphp.c>
        suPHP_UserGroup daowenpu daowenpu
</IfModule>

<Directory "/home/***/public_html/scriptophobia">
        AllowOverride All
</Directory>

</VirtualHost>
# vhost_end scriptophobia.com

Offline
*
Re: Getting error when requesting SSL cert
« Reply #5 on: August 29, 2017, 09:17:39 AM »
this can be related with the htaccess in the /home/***/public_html/ folder, you can test that by removing that addon domain and adding it again but into folder like this /home/***/scriptophobia
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/