Author Topic: Problem when I add ssl  (Read 11162 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Problem when I add ssl
« on: March 24, 2015, 09:08:32 AM »
First thing shows me

Code: [Select]
# vhost_start site.com
<Virtualsite 11.111.111.111:443>
 ServerName site.com
 ServerAlias www.site.com
 DocumentRoot /home/site/public_html
 SSLEngine on
 SSLCertificateFile /etc/pki/tls/certs/site.com.cert
 SSLCertificateKeyFile /etc/pki/tls/private/site.com.key
 SSLCertificateChainFile /etc/pki/tls/certs/site.com.bundle
<IfModule mod_suexec.c>
    SuexecUserGroup site site
</IfModule>

<IfModule mod_suphp.c>
    suPHP_UserGroup host site
    suPHP_ConfigPath /home/site
</IfModule>

<Directory "/home/site/public_html">
    AllowOverride All
</Directory>
</VirtualHost>
# vhost_end site.com

SUCCESS! SSL Certificate for domain site.com installed in: /usr/local/apache/conf.d/vhosts-ssl.conf !
SUCCESS! SSL Certificate added to CWP configuration file


And stops Apache

Stopping httpd: [  OK  ]
Starting httpd: Syntax error on line 34 of /usr/local/apache/conf.d/vhosts-ssl.conf:
SSLCertificateFile: file '/etc/pki/tls/certs/site.com.cert' does not exist or is empty
[FAILED

https works without a problem you do through checking this site
https://www.sslshopper.com/ssl-checker.html
« Last Edit: March 24, 2015, 09:11:02 AM by mekosaad »

Offline
*
Re: Problem when I add ssl
« Reply #1 on: March 24, 2015, 10:40:20 AM »
that file is empty

you need to edit that file and add your certificate key in

Offline
*
Re: Problem when I add ssl
« Reply #2 on: March 24, 2015, 11:30:29 AM »
Already this file does not exist, but where you bring him  :-[

When I enter the
Location of Certificate files /etc/pki/tls/certs/

This problem appears

Code: [Select]
Deprecated: Function ereg() is deprecated in /usr/local/cwpsrv/htdocs/resources/admin/modules/file_manager.php(1) : eval()'d code(1) : eval()'d code on line 212
/etc/pki/tls/certs/111111.com.crt
« Last Edit: March 24, 2015, 11:41:03 AM by mekosaad »

Offline
*
Re: Problem when I add ssl
« Reply #3 on: March 24, 2015, 12:24:33 PM »
are you using purchase ssl or self signed?


Offline
*
Re: Problem when I add ssl
« Reply #4 on: March 24, 2015, 12:29:01 PM »

Re: Problem when I add ssl
« Reply #5 on: March 24, 2015, 02:24:36 PM »
Why dont you redo whole process again?

Offline
*
Re: Problem when I add ssl
« Reply #6 on: March 24, 2015, 04:54:24 PM »
Why dont you redo whole process again?

I do not understand I'm bad in the English

Offline
*
Re: Problem when I add ssl
« Reply #7 on: March 24, 2015, 05:35:15 PM »
try by generating a new SSL and installing it
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: Problem when I add ssl
« Reply #8 on: March 24, 2015, 06:06:30 PM »
I've created a new key ssl
But again Apache stop

Code: [Select]
Stopping httpd: [  OK  ]
Starting httpd: httpd: Could not reliably determine the server's fully qualified domain name, using Server.111111.com for ServerName
[Tue Mar 24 18:17:07 2015] [warn] NameVirtualHost 11.22.33.44:80 has no VirtualHosts
[FAILED]

How do I turn Port ssl with Apache ???
« Last Edit: March 24, 2015, 06:18:53 PM by mekosaad »

Re: Problem when I add ssl
« Reply #9 on: March 24, 2015, 06:27:49 PM »
I dont think this error is related to ssl.

Offline
*
Re: Problem when I add ssl
« Reply #10 on: March 24, 2015, 06:29:49 PM »
I dont think this error is related to ssl.

When I delete ssl for this site is working again Apache

Re: Problem when I add ssl
« Reply #11 on: March 24, 2015, 07:06:39 PM »
Can you please explain how you are generating and signing certificate?

Offline
*
Re: Problem when I add ssl
« Reply #12 on: March 24, 2015, 07:27:56 PM »
Can you please explain how you are generating and signing certificate?

First you make a ssl certificate from SSL Generator
Second, download the file that was sent by the company comodo 11111_com.crt
To this place /etc/pki/tls/certs
Third, you have to enter this SSL Certs Manager
Also when I enter Location of Certificate files /etc/pki/tls/certs/
There data are is not empty like every time
« Last Edit: March 24, 2015, 07:29:42 PM by mekosaad »

Re: Problem when I add ssl
« Reply #13 on: March 24, 2015, 07:50:09 PM »
Now I am actually getting what issue you have. There is some bug in ssl generation process. Give me sometime I will try to explain you another way of adding ssl if possible.

Re: Problem when I add ssl
« Reply #14 on: March 24, 2015, 07:57:50 PM »
delete everything from this file: /usr/local/apache/conf.d/vhosts-ssl.conf

/etc/pki/tls/certs
delete your domain certificates files from here .crt,.cert,.bundle

/etc/pki/tls/private
delete your domain key file

Goto ssl generator fillin the entries and at the bottom also tick generate self signed certificate. Now generate ssl

Now this will generate csr, crt and key file.

Now you can goto ssl cert manager and complete rest of the process.