Author Topic: Syntax error on line 2 of /usr/local/apache/conf.d/ssl.conf:  (Read 283 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Syntax error on line 2 of /usr/local/apache/conf.d/ssl.conf:
« on: April 14, 2017, 10:16:53 AM »
Hello guys,

I got this issue when starting my httpd after updating CWP6Pro

AH00526: Syntax error on line 2 of /usr/local/apache/conf.d/ssl.conf:
Invalid command 'SSLCipherSuite', perhaps misspelled or defined by a module not included in the server configuration
[FAILED]

I had SSL before, but now I'm getting this and apache won't start.

I tried adding LoadModule ssl_module modules/mod_ssl.so but then I get another problem of something 98 already there port 80...

what should I do?

Thanks

Offline
*
Re: Syntax error on line 2 of /usr/local/apache/conf.d/ssl.conf:
« Reply #1 on: April 14, 2017, 08:06:48 PM »
edit your file /usr/local/apache/conf.d/ssl.conf and add this into it but delete all old from it

Code: [Select]
<IfModule !ssl_module>
LoadModule ssl_module modules/mod_ssl.so
</IfModule>
Listen 443
SSLProtocol All -SSLv2 -SSLv3
SSLHonorCipherOrder on
SSLCipherSuite ECDH+AESGCM:DH+AESGCM:ECDH+AES256:DH+AES256:ECDH+AES128:DH+AES:ECDH+3DES:DH+3DES:RSA+AESGCM:RSA+AES:RSA+3DES:!aNULL:!MD5:!DSS

then restart your httpd, if you still get the issue about the ports then you can rebuild vhosts by using rebuild vhosts option in the cwp under "Apache" menu.
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services