Author Topic: CWP - Centos 7 - Letsencrypt SSL stop work after update  (Read 252 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
CWP - Centos 7 - Letsencrypt SSL stop work after update
« on: October 24, 2017, 09:29:57 PM »
Hello to all,
I'm writing because after a yum update comand, all ssl domain stop work, and actuallu all domains are like "insecure connection".

I followed this links:
http://forum.centos-webpanel.com/ssl/hostname-ssl-with-letsencrypt-after-upgrade
https://serverfault.com/questions/854599/letsencrypt-auto-not-working-after-centos-update

in the first link is explained a solution, I changed apache configuration like counsel, but it don't fix my situation.

I looked for files, or old files of letecnrypt, without a solution.

Also I see the counsil of Sandeep, of use auto ssl from ssl category, is this after recongized by broswer by a valid certificato or is an auto ssl?

In any case, acually I need restore the domain ssl, please can you say a way to fix it, or files where I have to work.

Thank you for your high quality work.

« Last Edit: October 24, 2017, 09:31:48 PM by HRian »

Offline
*
Re: CWP - Centos 7 - Letsencrypt SSL stop work after update
« Reply #1 on: October 25, 2017, 03:54:34 PM »
solution to use letencrypt

sudo git clone https://github.com/letsencrypt/letsencrypt /opt/letsencrypt

cd /opt/letsencrypt

service httpd stop

sudo -H ./letsencrypt-auto certonly --standalone -d example.com -d www.example.com

service httpd start

go in CWP interface and install certificate by interface following this tutorial
http://wiki.centos-webpanel.com/letsencrypt-free-ssl-on-cwp

Repeat this process for each domain, or when stopped apache, you can create all , and wehn restart apache, install all