Author Topic: Error building php-fpm73 with memcached  (Read 1234 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Error building php-fpm73 with memcached
« on: December 20, 2018, 12:32:50 PM »
Hello.

FPM builds successfully and it's working with all options but memcached (not available). Reading the build log, I found this:

cc -I/opt/alt/php-fpm73/usr/include/php -I. -I/usr/local/src/php-memcached -DPHP_ATOM_INC -I/usr/local/src/php-memcached/include -I/usr/local/src/php-memcached/main -I/usr/local/src/php-memcached -I/opt/alt/php-fpm73/usr/include/php -I/opt/alt/php-fpm73/usr/include/php/main -I/opt/alt/php-fpm73/usr/include/php/TSRM -I/opt/alt/php-fpm73/usr/include/php/Zend -I/opt/alt/php-fpm73/usr/include/php/ext -I/opt/alt/php-fpm73/usr/include/php/ext/date/lib -I/usr/local/include -DHAVE_CONFIG_H -g -O2 -I/opt/alt/php-fpm73/usr/include/php -I/opt/alt/php-fpm73/usr/include/php/main -I/opt/alt/php-fpm73/usr/include/php/TSRM -I/opt/alt/php-fpm73/usr/include/php/Zend -I/opt/alt/php-fpm73/usr/include/php/ext -I/opt/alt/php-fpm73/usr/include/php/ext/date/lib -I/usr/local/include -c /usr/local/src/php-memcached/php_memcached.c  -fPIC -DPIC -o .libs/php_memcached.o
/usr/local/src/php-memcached/php_memcached.c: In function 'zim_Memcached___construct':
/usr/local/src/php-memcached/php_memcached.c:1282:20: error: lvalue required as left operand of assignment
   GC_REFCOUNT(&le) = 1;
                    ^
make: *** [php_memcached.lo] Error 1


And after that build continues without memcached module. Any clue?

Thanks in advance :)

Offline
*
Re: Error building php-fpm73 with memcached
« Reply #1 on: December 20, 2018, 01:08:21 PM »
I reply to myself: libmemcached is still not available for php 7.3 :(

Offline
*
Re: Error building php-fpm73 with memcached
« Reply #2 on: April 09, 2019, 04:14:05 PM »
I'm not sure if this is acceptable, but I manually compiled PHP 7.3.3. I forgot a few modules I needed, later installed them from remi and then copied to the appropriate path for my compiled version. I finally had to edit php.ini to enable the extensions.

I'd really like to hear how others are dealing with this. PHP 5.6 is not appropriate for me.

Thanks, Bren