Author Topic: Issues After version: 0.9.8.742 Update  (Read 496 times)

0 Members and 1 Guest are viewing this topic.

Offline
***
Issues After version: 0.9.8.742 Update
« on: December 02, 2018, 09:45:40 PM »
After the update, I have trouble with WordPress mixed content and break css. Magento just keep on redirecting until browser give up. If I run only Apache then everything work. Anything else will not work. Anyone knows how to fixed this?


Offline
*
Re: Issues After version: 0.9.8.742 Update
« Reply #2 on: December 03, 2018, 11:59:21 AM »
all of my website behaving wrong, only default page being shown.

Offline
*
Re: Issues After version: 0.9.8.742 Update
« Reply #3 on: December 05, 2018, 03:07:36 PM »
What u use? Apache ningx varnish or? I had loop problem i solve it setting default WebServer in nginx insted php-fpm. Also rebuild apache, and php to latest version. And remove all configs ( if u have) in domain conf.

Offline
*
Re: Issues After version: 0.9.8.742 Update
« Reply #4 on: December 08, 2018, 08:50:47 AM »
Very educative. but can this streaming Website 123Movies or MovieBox Update use it?

Offline
***
Re: Issues After version: 0.9.8.742 Update
« Reply #5 on: December 08, 2018, 10:13:39 AM »
What u use? Apache ningx varnish or? I had loop problem i solve it setting default WebServer in nginx insted php-fpm. Also rebuild apache, and php to latest version. And remove all configs ( if u have) in domain conf.

I'm using NginX+Varnish+Apache and now + PHP-FPM too. I found the problem. It's when you're using https you get some resources requested from insecure http. That causes the mixed content. I found the solution to it by adding this to my htaccess to force https.
Code: [Select]
SetEnvIf X-Forwarded-Proto "https" HTTPS=on
<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{HTTPS} !=on
RewriteCond %{HTTP:X-Forwarded-Proto} !https [NC]
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
</IFModule>
That works for me. But I wish someone can come up with a solution for server end so we don't have to do this every times. I think it can be done through vhost but I don't know how.

Offline
***
Re: Issues After version: 0.9.8.742 Update
« Reply #6 on: December 08, 2018, 11:21:15 AM »
If you're using WordPress then you have another option. That is to add this to your wp-config.php.

Code: [Select]
if ($_SERVER['HTTP_X_FORWARDED_PROTO'] == 'https')
    $_SERVER['HTTPS']='on';

if (isset($_SERVER['HTTP_X_FORWARDED_HOST'])) {
    $_SERVER['HTTP_HOST'] = $_SERVER['HTTP_X_FORWARDED_HOST'];
}