Author Topic: RBL not added to postfix main.cf  (Read 7057 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
RBL not added to postfix main.cf
« on: April 10, 2016, 09:41:52 AM »
Hi, in the CWP I have enabled the Spamhaus antispam option. I did however receive a considerable amount of spam and therefore checked the main.cf and I see that spamhaus is not added to the reject line for some reason...?
I know how to add it, but I wonder why it isneīt added when it clearly states in the CWP dashboard that Spamhaus is installed....?

Perhaps it is clearing even before going to postfix as it is integrated with the csf firewall? I do however not see it in eg. the deny IPīs in csf....

Checking mail log also shows no rejections at all by spamhaus....

Anybody know if this is a bug or...?


Ok - I tried to experiment with setting up spamhaus check by directly inserting it into main cf and immediately I saw that spamhaus now is filtering - this clearly shows that the CWP plugin/option does NOT work as supposed - if it worked it would not be possible to have the direct edit giving spamhaus results in the maillog as it would already have been filtered by the cwp install and/or the cwp install would show reesults in the maillog...

This indicates clearly that there is a bug in the antispam feature in cwp, whether it is only my installation or a general bug I have no idea, I can only document that in my installation it does not work at all...

For others with the same problem I would suggest editing main.cf directly or do it via installing an interface like webmin to edit it there ( a little easier for non-nerds or non-specialists)  8)

« Last Edit: April 11, 2016, 08:40:03 AM by muscator »

Offline
*
Re: RBL not added to postfix main.cf
« Reply #1 on: October 23, 2020, 03:55:56 AM »
Can anyone share how to access the main.cf, need to add spamrat rbl.

Offline
*
Re: RBL not added to postfix main.cf
« Reply #2 on: December 07, 2020, 10:52:13 AM »
Mine config is:

Code: [Select]
# rules restrictions
smtpd_client_restrictions =
  permit_mynetworks,
permit_sasl_authenticated,
reject_unauth_pipelining,
reject_unknown_address,
reject_unknown_client_hostname
   
smtpd_helo_restrictions =
    permit_mynetworks,
    permit_sasl_authenticated,
    reject_non_fqdn_helo_hostname,
    reject_unknown_helo_hostname

smtpd_sender_restrictions =
    permit_sasl_authenticated,
    permit_mynetworks,
# check_client_access hash:/etc/postfix/white_client_access,
# check_recipient_access hash:/etc/postfix/white_recipient_access,
    reject_invalid_hostname,
    reject_non_fqdn_hostname,
    reject_non_fqdn_sender,
    reject_unknown_client_hostname,
    reject_unknown_reverse_client_hostname,
    reject_unknown_sender_domain,
    reject_unknown_hostname,
    reject_unlisted_sender,
    reject_rbl_client zombie.dnsbl.sorbs.net,
    reject_rbl_client cbl.abuseat.org,
    reject_rbl_client zen.spamhaus.org,
    reject_rbl_client bl.spamcop.net,
    reject_rbl_client dnsbl.sorbs.net,
    reject_rbl_client spam.dnsbl.anonmails.de,
    reject_rbl_client b.barracudacentral.org,
    reject_rbl_client z.mailspike.net,
    reject_rhsbl_sender dbl.spamhaus.org,
    reject_rhsbl_sender db.wpbl.info,
    reject_rhsbl_sender psbl.surriel.com,
    permit

smtpd_recipient_restrictions =
  permit_sasl_authenticated,
  permit_mynetworks,
# check_client_access hash:/etc/postfix/access,
# check_recipient_access hash:/etc/postfix/recipient_access,
  reject_unauth_destination,
  reject_non_fqdn_sender,
  reject_non_fqdn_recipient,
  reject_unknown_recipient_domain,
  reject_invalid_hostname,
  reject_non_fqdn_hostname,
  reject_unauth_pipelining,
  reject_unlisted_recipient,
  reject_multi_recipient_bounce,
  reject_rbl_client zombie.dnsbl.sorbs.net,
  reject_rbl_client cbl.abuseat.org,
  reject_rbl_client zen.spamhaus.org,
  reject_rbl_client bl.spamcop.net,
  reject_rbl_client spam.dnsbl.anonmails.de,
  reject_rbl_client b.barracudacentral.org,
  reject_rbl_client z.mailspike.net,
  reject_rbl_client dnsbl.sorbs.net,
  reject_rhsbl_helo dbl.spamhaus.org,
  reject_rhsbl_reverse_client dbl.spamhaus.org,
  permit

For Spamrat you need to add:
Code: [Select]
    reject_rbl_client dyna.spamrats.com

Note of the tab in the beginning of each parameter line - this is mandatory.
« Last Edit: December 07, 2020, 10:55:07 AM by Hardoman »