Author Topic: Webpage not correct  (Read 10235 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Webpage not correct
« on: March 22, 2015, 09:29:42 PM »
Hello guys!

I have a problem and I need your help.

My problem is that I got the default page on all my sites.
Probally you are going to say this is a repost but I really cant fix it, I got this problem for a few days now.


I did the steps in the tutorials;
http://forum.centos-webpanel.com/apache/default-page-displayed-for-all-domains/
&&
http://wiki.centos-webpanel.com/default-page-displayed-for-all-domains

Still getting the default page for all the sites.

My internal IP is 192.168.178.34 for the server and external is 94.213.xxx.xx;

This is my vhost of one of the sites
-----------------
# vhost_start cirosilmedia.com
<VirtualHost 94.213.xxx.xx:80>
ServerName cirosilmedia.com
ServerAlias cirosilmedia.com
ServerAdmin ADMIN@ADMINEMAIL.com
DocumentRoot "/home/cirosil/public_html"
ScriptAlias /cgi-bin/ "/home/cirosil/public_html/cgi-bin/
#
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/cirosil/cirosilmedia.com/*.conf

<IfModule mod_suexec.c>
        SuexecUserGroup cirosil cirosil
</IfModule>

<IfModule mod_suphp.c>
        suPHP_UserGroup cirosil cirosil
        suPHP_ConfigPath /home/cirosil
</IfModule>

<Directory "/">
        AllowOverride All
</Directory>

</VirtualHost>
# vhost_end cirosilmedia.com



I also tried it with:

<Directory "/home/cirosil/public_html">
        AllowOverride All
</Directory>


Thanks in advance!

Regards,

Bosman

Re: Webpage not correct
« Reply #1 on: March 22, 2015, 10:00:51 PM »
Do you have Vhost entries for all your websites?

Offline
*
Re: Webpage not correct
« Reply #2 on: March 23, 2015, 09:02:55 AM »
I got this for every site I got in cwp, 3 in total;


-----
# vhost_start ihazop.nl
<VirtualHost 94.213.xxx.xx:80>
ServerName ihazop.nl
ServerAlias ihazop.nl
ServerAdmin admin[AT]admin.com
DocumentRoot "/home/ihazop/public_html"
ScriptAlias /cgi-bin/ "/home/ihazop/public_html/cgi-bin/"
#
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/ihazop/ihazop.nl/*.conf

<IfModule mod_suexec.c>
        SuexecUserGroup ihazop ihazop
</IfModule>

<IfModule mod_suphp.c>
        suPHP_UserGroup ihazop ihazop
        suPHP_ConfigPath /home/ihazop
</IfModule>

<Directory "/home/ihazop/public_html">
        AllowOverride All
</Directory>

</VirtualHost>
# vhost_end ihazop.nl

# vhost_start point-zero.biz
<VirtualHost 94.213.xxx.xx:80>
ServerName point-zero.biz
ServerAlias point-zero.biz
ServerAdmin admin[AT]admin.com
DocumentRoot "/home/pointzer/public_html"
ScriptAlias /cgi-bin/ "/home/pointzer/public_html/cgi-bin/"
#
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/pointzer/point-zero.biz/*.conf

<IfModule mod_suexec.c>
        SuexecUserGroup pointzer pointzer
</IfModule>

<IfModule mod_suphp.c>
        suPHP_UserGroup pointzer pointzer
        suPHP_ConfigPath /home/pointzer
</IfModule>

<Directory "/home/pointzer/public_html">
        AllowOverride All
</Directory>

</VirtualHost>
# vhost_end point-zero.biz

# vhost_start cirosilmedia.com
<VirtualHost 94.213.xxx.xx:80>
ServerName cirosilmedia.com
ServerAlias cirosilmedia.com
ServerAdmin admin[AT]admin.com
DocumentRoot "/home/cirosil/public_html"
ScriptAlias /cgi-bin/ "/home/cirosil/public_html/cgi-bin/"
#
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/cirosil/cirosilmedia.com/*.conf

<IfModule mod_suexec.c>
        SuexecUserGroup cirosil cirosil
</IfModule>

<IfModule mod_suphp.c>
        suPHP_UserGroup cirosil cirosil
        suPHP_ConfigPath /home/cirosil
</IfModule>

<Directory "/home/cirosil/public_html">
        AllowOverride All
</Directory>
</VirtualHost>

# vhost_end cirosilmedia.com

Re: Webpage not correct
« Reply #3 on: March 23, 2015, 05:06:38 PM »
did u try restarting apache?

service httpd restart

Offline
*
Re: Webpage not correct
« Reply #4 on: March 24, 2015, 10:08:52 AM »
Yesh, I did restart it multiple times and rebooted the server also.

Re: Webpage not correct
« Reply #5 on: March 24, 2015, 11:43:39 AM »
Without looking inside it will be hard to help. I think just by paying 5$ to the centos web panel team they can help to get this issue resolved.

Offline
*
Re: Webpage not correct
« Reply #6 on: March 24, 2015, 04:26:10 PM »
you will need to check on your shared ip address and check if you have varnish enabled.
Also rebuild apache vHosts could help
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: Webpage not correct
« Reply #7 on: April 07, 2015, 07:51:41 PM »
Okay I found fixed it myself!

I changed in the vhosts;
<VirtualHost SERVER_IP:80> to <VirtualHost *:80>

I changed in sharedip.conf
NameVirtualHost SERVER_IP:80 to *:80;

Then restart httpd/apache and I got it working.

Regards,

Bosman.