Author Topic: Cgroups (Disk I/O) still not working  (Read 2574 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Cgroups (Disk I/O) still not working
« on: May 27, 2020, 01:57:32 PM »
Hi there,

The cgroups seems to be not working when enabling Disk I/O this happened since the past maybe 2 updates.

I'm wondering if anybody experiencing the same issue?

Note: When disabling Disk I/O Cgroups is able to work but with the recent update of Centos 7 & CWP things got bugged down.

Screenshot:
https://prnt.sc/sosut2

Error shown:
Code: [Select]
systemctl status cgconfig.service
● cgconfig.service - Control Group configuration service
   Loaded: loaded (/usr/lib/systemd/system/cgconfig.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Wed 2020-05-27 08:58:54 CDT; 23s ago
  Process: 6444 ExecStop=/usr/sbin/cgclear -l /etc/cgconfig.conf -L /etc/cgconfig.d -e (code=exited, status=0/SUCCESS)
  Process: 6543 ExecStart=/usr/sbin/cgconfigparser -l /etc/cgconfig.conf -L /etc/cgconfig.d -s 1664 (code=exited, status=109)
 Main PID: 6543 (code=exited, status=109)

May 27 08:58:54 us1.xtrahosting.net cgconfigparser[6543]: Error: failed to set /sys/fs/cgroup/blkio/secchase/blkio.throttle.write_bps_device: Invalid argument
May 27 08:58:54 us1.xtrahosting.net cgconfigparser[6543]: Error: failed to set /sys/fs/cgroup/blkio/testermc/blkio.throttle.read_bps_device: Invalid argument
May 27 08:58:54 us1.xtrahosting.net cgconfigparser[6543]: Error: failed to set /sys/fs/cgroup/blkio/testermc/blkio.throttle.write_bps_device: Invalid argument
May 27 08:58:54 us1.xtrahosting.net cgconfigparser[6543]: Error: failed to set /sys/fs/cgroup/blkio/xtradmin/blkio.throttle.read_bps_device: Invalid argument
May 27 08:58:54 us1.xtrahosting.net cgconfigparser[6543]: Error: failed to set /sys/fs/cgroup/blkio/xtradmin/blkio.throttle.write_bps_device: Invalid argument
May 27 08:58:54 us1.xtrahosting.net cgconfigparser[6543]: Error: failed to set /sys/fs/cgroup/blkio/xtrapos/blkio.throttle.read_bps_device: Invalid argument
May 27 08:58:54 us1.xtrahosting.net cgconfigparser[6543]: Error: failed to set /sys/fs/cgroup/blkio/xtrapos/blkio.throttle.write_bps_device: Invalid argument
May 27 08:58:54 us1.xtrahosting.net systemd[1]: Failed to start Control Group configuration service.
May 27 08:58:54 us1.xtrahosting.net systemd[1]: Unit cgconfig.service entered failed state.
May 27 08:58:54 us1.xtrahosting.net systemd[1]: cgconfig.service failed.
« Last Edit: May 27, 2020, 01:59:48 PM by xtrahosting »

Offline
*
Re: Cgroups (Disk I/O) still not working
« Reply #1 on: July 22, 2021, 01:17:42 PM »
Dear Team,
I face the same issue.
CWPpro version: 0.9.8.1078
Centos 7.9
Any help will be highly appreciated.
Thank you

Offline
*
Re: Cgroups (Disk I/O) still not working
« Reply #2 on: November 18, 2021, 09:22:28 PM »
Dear @techtroves, I also face this issue for last few month as well. But today able to enable CPU,Memory & Disk I/O limit. So, CWP team may be fixed the issue with the latest version. My current version is 0.9.8.1101
Biswas Host Ltd

www.biswashost.com

Domain, Hosting, Cloud Hosting, VPS, Dedicated Server,

Web Design, SSL, VPN, Professional Email & More

Offline
*
Re: Cgroups (Disk I/O) still not working
« Reply #3 on: November 19, 2021, 02:21:15 PM »
changelog says it was fixed in version 0.9.8.1094 (19/10/2021)
https://control-webpanel.com/changelog
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*****
Re: Cgroups (Disk I/O) still not working
« Reply #4 on: November 24, 2021, 05:54:13 PM »
try to remove cgroups and reinstall from cwp gui