Author Topic: problems with databases  (Read 11545 times)

0 Members and 1 Guest are viewing this topic.

Offline
***
problems with databases
« on: February 08, 2016, 03:19:06 PM »
Hi,

recently I use Centos web panel. My ISP installs it as server and create an account for me ... but meeting me problems with databases asking for a little help ...

I cleaned all the bases and the user. In the panel and login I created a new database named venci_sss. Walked into phpmyadmin to set up my base and create a new table named nova_test and its structure id, fname, lname, here everything I was normal ... so now created a table please tell me how to bring value in the id 1, fname Ventsislav, lname Krastev .. and then as I do not like Krastev change it to Krustev ....???


But what I want to install prestashop originally seen that has a base and users now to her, but then at installations and returns

=
Populate database tables error
Аn error occurred during installation...


BR
Venty
« Last Edit: February 08, 2016, 08:13:36 PM by venty »

Offline
***
Re: problems with databases
« Reply #1 on: February 09, 2016, 03:28:22 PM »
U should set the type of every item you created on the table nova_test.
Also, phpmyadmin has a tab named "Operations" that allow you to modify AUTO_INCREMENT of id, when you set them as index (auto-increment explicit).

So, that's the full SQL to create table nova_test if do not exist, then create the structure and a data row.
U can try it in that phpmyadmin full working demo. Put root at user then press enter. No passwd. http://demo.phpmyadmin.net/master/
Click the SQL tab at upper bar then paste the following code. I added also the reg_date with TIMESTAMP to show you.
U can create a secondary table with same structure and it will be updated with current date, as login monitor.

* Note that ID is default and autoincrement. You have to pass "" or NULL to make it work auto. If you run a query adding a custom number it would get it and probably crash when the counter reachs it.

Code: [Select]
CREATE DATABASE IF NOT EXISTS `venci_sss`;
USE venci_sss;

CREATE TABLE IF NOT EXISTS `nova_test` (
  `id` int(11) NOT NULL,
  `fname` varchar(100) NOT NULL DEFAULT '',
  `lname` varchar(100) NOT NULL DEFAULT '',
  `reg_date` TIMESTAMP NOT NULL DEFAULT CURRENT_TIMESTAMP,
  PRIMARY KEY (`id`)
) ENGINE=MyISAM  DEFAULT CHARSET=latin1 COMMENT='Table for testing' AUTO_INCREMENT=0;

INSERT INTO nova_test (id, fname, lname)
VALUES ("", "Ventsislav", "Krustev");
8==D it's a function that try to compare 8 (int) against D (string) which returns True or False depending on the asker.

Offline
***
Re: problems with databases
« Reply #2 on: February 09, 2016, 03:33:43 PM »
OK!

But I want to install prestashop, but then at installations and returns:

Populate database tables error
Аn error occurred during installation...


BR
Venty

Offline
***
Re: problems with databases
« Reply #3 on: February 09, 2016, 03:48:16 PM »
Create databases from the CWP menu.
Once you do that, simply fill the Prestashop data and everything should be ok.

That error about populate seems = you are not using a user with perms to list databases, or = you dont assign your user to any database.
That kind of operation are handled by the panel, and you don't really need phpmyadmin to install Prestashop on your CWP.

I've work a lot of times with Prestashop, if you need support for Prestashop go to it's forum.
8==D it's a function that try to compare 8 (int) against D (string) which returns True or False depending on the asker.

Offline
***
Re: problems with databases
« Reply #4 on: February 09, 2016, 04:10:01 PM »
Hi,

Problem is not in prestashop, I got the account for CWP, from my provider and enter with him in CWP.
In CWP the panel I create database with name, username and password.

How do I know that my users now so established the base in CWP has the necessary perms...???
... and if users not perms???

...as the panel I can create only the name of the base,  name of users and password?!?

BR
Venty

Offline
***
Re: problems with databases
« Reply #5 on: February 09, 2016, 04:29:07 PM »
In the SQL manager menu, you got:
 List Databases and Users | List Users | Create Database | Create Database and User

So, if you created a database, you'll see it on the list, and you'll have a link at right side with "create user".

Code: [Select]
Add New User for Database: information_schema
Username: information_ (max 7 characters)
Host:
Confirm New Password: (random generator)
Confirm New Password:

So, if you created a database from user admin, database will be admin_name, and the users would be admin_name too.
Just create the pair, DATABASE AND USER, then fill that data on the Prestashop.
8==D it's a function that try to compare 8 (int) against D (string) which returns True or False depending on the asker.

Offline
***
Re: problems with databases
« Reply #6 on: February 17, 2016, 06:39:59 PM »
 :(
Hi,

I created a database, ...in the panel I see it on the list, but ....

I want to install PRSTASHOP, but then at installations and returns

Populate database tables
An error occurred during installation...
You can use the links on the left column to go back to the previous steps, or restart the installation process by clicking here.

BR
Venty :(


Offline
*****
Re: problems with databases
« Reply #7 on: February 19, 2016, 06:01:12 AM »
Hello.

Try to ask your developer about it or somebody, who can using Linux.
Also you can contact with our support:  http://centos-webpanel.com/support-services
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
***
Re: problems with databases
« Reply #8 on: February 21, 2016, 03:54:23 PM »
HI,

I have my server machine, my administrator is a man who knows  and who can using Linux...., He install CWP,We have created user, it creates domains and databases, but when I want manually install prestasshop, joomla or joomla_Quickstart_package and SMF forum does not work?!?

When I use Softatsulous, the installation is in good ???

For several reasons, I do not want to use Softatsulous...

Obviously I will not get away without using support you, but please tell me which package them I choose to check everything - my server, and my CWP and also I need help so that manually installations  prestasshop, joomla or joomla_Quickstart_package and SMF forum must be happen...

BR
Venty

Offline
*
Re: problems with databases
« Reply #9 on: February 22, 2016, 06:31:06 AM »
you can contact support about your issues here
http://centos-webpanel.com/contact
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
***
Re: problems with databases
« Reply #10 on: February 22, 2016, 10:33:45 AM »
Hi,

I looked server logs and is filled with rows of type:

[Mon Feb 22 12:08:59 2016] [error] [client 213.16.32.22] PHP Warning:  Error while sending QUERY packet. PID=25623 in /home/venci/public_html/cmarket.eu/classes/db/DbPDO.php on line 134, referer: http://www.cmarket.eu/install/index.php?restart=true

or

[Mon Feb 22 11:48:24 2016] [error] [client 213.16.32.22] File does not exist: /home/venci/public_html/ilogistics.eu/favicon.ico

and many others of the same species...

what to do to get it working, I can not install or prestashop or joomla_Quickstart_package...

errors in PHP and missing files, and I check they are available in folder?!?

BR
Venty


Offline
*
Re: problems with databases
« Reply #11 on: February 22, 2016, 04:34:05 PM »
You can ignore the "/home/venci/public_html/ilogistics.eu/favicon.ico" related error, it's just that that domain doesn't have a favourite icon installed and Apache gives that error every time someone requests a file that is not there (most browsers search for favicon.ico).

About the other error: Sadly the errror message is not very helpful, but did you set the database user and database and database password in the Prestashop install correctly? I am guessing it has problems connecting to your MYSQL database. Also as host you should set
localhost
!