Author Topic: PHP Version Switcher - Error rebuild PHP 7.3.6  (Read 227 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
PHP Version Switcher - Error rebuild PHP 7.3.6
« on: June 08, 2019, 06:22:54 PM »
Quote
## Application Version
Apache version: Apache/2.4.39
PHP version: 7.3.6 [PHP Switcher]
MySQL version: 10.1.40-MariaDB
FTP version: 1.0.47

## System Info
CPU Model: Intel(R) Xeon(R) CPU E5-2676 v3 @ 2.40GHz
CPU Details: 1 Core (2400 MHz)
Distro Name: CentOS Linux release 7.6.1810 (Core)
Kernel Version: 3.10.0-957.12.2.el7.x86_64
Platform: x86_64 [xenxen-hvmaws]

=================================================================

Erro:


Code: [Select]
'loader-wizard.php' -> '/usr/local/ioncube/loader-wizard.php'
yes: standard output: Broken pipe
yes: write error












Offline
*****
Re: PHP Version Switcher - Error rebuild PHP 7.3.6
« Reply #1 on: June 08, 2019, 10:57:58 PM »
Please run php -v to check if under zend modules, there is ioncube installed

Offline
*
Re: PHP Version Switcher - Error rebuild PHP 7.3.6
« Reply #2 on: June 09, 2019, 12:51:30 AM »
Please run php -v to check if under zend modules, there is ioncube installed

I ran the command: php -v


Code: [Select]
[centos@srv1 ~]$ php -v
PHP Warning:  PHP Startup: Unable to load dynamic library 'memcached.so' (tried: /usr/local/lib/php/extensions/no-debug-non-zts-20180731/memcached.so (/usr/local/lib/php/extensions/no-debug-non-zts-20180731/memcached.so: cannot open shared object file: No such file or directory), /usr/local/lib/php/extensions/no-debug-non-zts-20180731/memcached.so.so (/usr/local/lib/php/extensions/no-debug-non-zts-20180731/memcached.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0
PHP 7.3.6 (cli) (built: Jun  8 2019 14:40:32) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.6, Copyright (c) 1998-2018 Zend Technologies
    with the ionCube PHP Loader + ionCube24 v10.3.5, Copyright (c) 2002-2019, by ionCube Ltd.
[centos@srv1 ~]$



What to do?

Offline
*****
Re: PHP Version Switcher - Error rebuild PHP 7.3.6
« Reply #3 on: June 09, 2019, 06:24:20 PM »
Zend Engine v3.3.6, Copyright (c) 1998-2018 Zend Technologies
    with the ionCube PHP Loader + ionCube24 v10.3.5, Copyright (c) 2002-2019, by ionCube Ltd.
[centos@srv1 ~]$

means ioncube is installed.

Did you check memcache when building php

Offline
*
Re: PHP Version Switcher - Error rebuild PHP 7.3.6
« Reply #4 on: June 09, 2019, 08:46:13 PM »
Zend Engine v3.3.6, Copyright (c) 1998-2018 Zend Technologies
    with the ionCube PHP Loader + ionCube24 v10.3.5, Copyright (c) 2002-2019, by ionCube Ltd.
[centos@srv1 ~]$

means ioncube is installed.

Did you check memcache when building php



I do not have much experience with this panel. I've always used cPanel.

I'm trying to use cwp, but this is difficult!

Offline
*
Re: PHP Version Switcher - Error rebuild PHP 7.3.6
« Reply #5 on: June 10, 2019, 01:17:23 AM »
I made a new installation now on digital ocean. You also have the same problem, see:

Code: [Select]
'ioncube_loader_lin_7.3_ts.so' -> '/usr/local/ioncube/ioncube_loader_lin_7.3_ts.so'
'loader-wizard.php' -> '/usr/local/ioncube/loader-wizard.php'
yes: standard output: Broken pipe
yes: write error


[6]+  Stopped                 tail -f /var/log/php-rebuild.log



[root@srv1 ~]# php -v

PHP 7.3.6 (cli) (built: Jun 10 2019 01:08:31) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.6, Copyright (c) 1998-2018 Zend Technologies
    with the ionCube PHP Loader + ionCube24 v10.3.5, Copyright (c) 2002-2019, by ionCube Ltd.
[root@srv1 ~]#