Author Topic: web panel 502 bad gateway error  (Read 3189 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
web panel 502 bad gateway error
« on: November 21, 2017, 12:36:19 PM »
Hi there,

All of a sudden I went to log in tonight to the web panel and found it doesn't not work. This is a fairly new installation that I set up to test. I hadn't changed anything at all but now when I got to their the normal or SSL page I get a 502 error bad gateway. have tried restarting, updating but no joy.

Any ideas?

Offline
***
Re: web panel 502 bad gateway error
« Reply #1 on: November 23, 2017, 07:17:23 AM »
Do you have nginx installed on the server? Have you tried to restart it?
https://www.24x7servermanagement.com/
Server Management, Server Security, Server Monitoring.
India's Leading Managed Service Provider !!

Offline
*
Re: web panel 502 bad gateway error
« Reply #2 on: November 25, 2017, 01:09:24 AM »
no i don't, it was a standard install with apache from memory. i can hit the normal webpage ok but the admin comes up with the 502.

Offline
*
Re: web panel 502 bad gateway error
« Reply #3 on: November 25, 2017, 07:58:49 PM »
this should fix it

sh /scripts/restart_cwpsrv

Offline
*
Re: web panel 502 bad gateway error
« Reply #4 on: November 26, 2017, 02:51:31 AM »
I've tried that and also rebooting but no joy...

I don't know where to look to see if something is causing a conflict..

Offline
*
Re: web panel 502 bad gateway error
« Reply #5 on: November 29, 2017, 03:30:32 PM »
Hi there,

All of a sudden I went to log in tonight to the web panel and found it doesn't not work. This is a fairly new installation that I set up to test. I hadn't changed anything at all but now when I got to their the normal or SSL page I get a 502 error bad gateway. have tried restarting, updating but no joy.

Any ideas?

Same issue here.. have you found any solution?

Offline
*
Re: web panel 502 bad gateway error
« Reply #6 on: November 29, 2017, 08:33:16 PM »
Hello there, I have a similar issue, today I have installed apache 7.0.24 + nginx + varnish resulting in not working cwp gui through localhost:2030. Yestarday the same procedure of installation was working. any solution?

Offline
*
Re: web panel 502 bad gateway error
« Reply #7 on: November 30, 2017, 04:35:15 AM »

Same issue here.. have you found any solution?

No luck as yet.. still a mystery

Offline
*
Re: web panel 502 bad gateway error
« Reply #8 on: January 29, 2019, 06:27:54 AM »
Do you have nginx installed on the server? Have you tried to restart it?

I have that installed, but i cant login to CWP via ip address or via domain, or FTP... nothing works

any suggestions?

thx

FTP log:

Status:   Connection established, waiting for welcome message...
Status:   Initializing TLS...
Error:   Server sent unsorted certificate chain in violation of the TLS specifications
Status:   Verifying certificate...
Status:   TLS connection established.
Response:   530 Sorry, but I can't trust you
Error:   Critical error: Could not connect to server
Status:   Disconnected from server
Status:   Connection established, waiting for welcome message...
Status:   Initializing TLS...
Error:   Server sent unsorted certificate chain in violation of the TLS specifications
Status:   Verifying certificate...
Status:   TLS connection established.
Response:   530 Login authentication failed
Error:   Critical error: Could not connect to server