Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - emar

Pages: [1] 2 3
1
CentOS-WebPanel Bugs / Re: SOLVED: mail not sending - permission denied
« on: February 23, 2021, 09:38:22 PM »
Thanks for referencing your fix, 5 years ago.  :)

2
It's a new server with 2 500 gig drives

3
This message keeps coming back to gmail

###################################################################
# THIS IS A WARNING ONLY.  YOU DO NOT NEED TO RESEND YOUR MESSAGE. #
####################################################################

Your message could not be delivered for more than 4 hour(s).
It will be retried until it is 5 day(s) old.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

<billing@domain.com>: temporary failure. Command output: Can't open log file
    /var/log/dovecot.log: Permission denied

I'm not sure what to fix, I can't receive emails to any email address in Roundcube, but I can send them out.
I did delete and recreate the dovecot.log it's current permissions are set to 600, root user.

Any help appreciated.

4
Hi,

Testing a few email accounts in Roundcube

I can send out emails but can't receive any, testing with gmail account.

Looked at /var/log/dovecot.log

Feb 15 04:07:36 imap(me@domain.it): Warning: autocreate plugin is deprecated, use mailbox { auto } setting instead

/var/log/maillog

Feb 15 04:28:59 svr1 postfix/smtpd[18842]: warning: unknown[ip]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
Feb 15 04:29:00 svr1 postfix/smtpd[19641]: warning: unknown[87.246.7.000]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
Feb 15 04:29:00 svr1 postfix/smtpd[18315]: warning: unknown[ip]: SASL LOGIN authentication failed: UGFzc3dvcmQ6
Feb 15 04:29:00 svr1 postfix/smtpd[18315]: disconnect from unknown[ip] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
Feb 15 04:29:00 svr1 postfix/smtpd[18809]: connect from unknown[ip]
Feb 15 04:29:00 svr1 postfix/smtpd[18842]: disconnect from unknown[ip] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
Feb 15 04:29:00 svr1 postfix/smtpd[19641]: disconnect from unknown[87.246.7.000] ehlo=1 auth=0/1 rset=1 quit=1 commands=3/4
Feb 15 04:29:03 svr1 postfix/smtpd[15533]: warning: hostname net6-ip000.linkbg.com does not resolve to address 87.246.7.000: Name or service not known
Feb 15 04:29:03 svr1 postfix/smtpd[15533]: connect from unknown[87.246.7.000]
Feb 15 04:29:03 svr1 postfix/smtpd[19486]: connect from unknown[ip]
Feb 15 04:29:04 svr1 postfix/smtpd[18315]: connect from unknown[ip]
Feb 15 04:29:05 svr1 postfix/smtpd[18842]: connect from unknown[ip]

Any advice appreciated

5
I can build it / Re: Boxbilling Integration
« on: November 08, 2020, 11:48:20 PM »
Hi,

How did you expand the products on the order page, there is no drop-down selector for each product,

I see you used whmcs bootstrap theme, but is that only for whmcs?

Thanks

6
I am able to access the website again, after I did the reload web server in ssl section,

I just did a google about:

nginx: [warn] the ssl directive is deprecated, use the listen ... ssl directive instead

I went to /etc/nginx/conf.d/vhosts/clients.dreamstream.it.ssl.conf:8
And deleted the line for: ssl                  on;
And added: listen 443 ssl;

Then did nginx -t and got:

user@ $ nginx -t
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

I guess that fixed it?

7
Thanks Igor,

I went to the SSL Certificates section and restarted the web server, then nginx was online.

I got this when I ran nginx -t

$ nginx -t
nginx: [warn] the "ssl" directive is deprecated, use the "listen ... ssl" directive instead in /etc/nginx/conf.d/vhosts/clients.dreamstream.it.ssl.conf:8
nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
nginx: configuration file /etc/nginx/nginx.conf test is successful

I am unable to restart the ftp server and Vanish Cache Server.

Also some of the mail services are down.

I'll start another thread for those.

8
Hi,

Distro Name: CentOS Linux release 7.7.1908 (Core)
Kernel Version: 2.6.32-042stab127.2

I'm having issues accessing my site,
I logged into CWP and see Nginx Reverse Proxy, FTP Server & Varnish Cache Server are down.

Just noticed some of the mail services failed to start too after server reboot.

Dovecot IMAP/POP3 Server      
ClamAV      
AMaViS (A Mail Virus Scanner)
SpamAssassin

Not sure how to fix all issues.

Here's some status info for Nginx Reverse Proxy..

● nginx.service - nginx - high performance web server
   Loaded: loaded (/usr/lib/systemd/system/nginx.service; enabled; vendor preset: disabled)
   Active: failed (Result: timeout) since Thu 2020-01-09 01:21:38 UTC; 2min 56s ago
     Docs: http://nginx.org/en/docs/
  Process: 28857 ExecStart=/usr/sbin/nginx -c /etc/nginx/nginx.conf (code=exited, status=0/SUCCESS)

Jan 09 01:20:08 clients systemd[1]: Starting nginx - high performance web server...
Jan 09 01:20:08 clients systemd[1]: Can't open PID file /var/run/nginx.pid (yet?) after start: Too many levels of symbolic links
Jan 09 01:21:38 clients systemd[1]: nginx.service start operation timed out. Terminating.
Jan 09 01:21:38 clients systemd[1]: Failed to start nginx - high performance web server.
Jan 09 01:21:38 clients systemd[1]: Unit nginx.service entered failed state.
Jan 09 01:21:38 clients systemd[1]: nginx.service failed.

-- Unit session-7789535.scope has finished starting up.
--
-- The start-up result is done.
Jan 09 01:00:01 clients CROND[25275]: (root) CMD (/usr/local/bin/php -q /home/dsm1/public_html/index.php cron > /dev/null 2>&1)
Jan 09 01:00:32 clients systemd[1]: nginx.service start operation timed out. Terminating.
Jan 09 01:00:32 clients systemd[1]: Failed to start nginx - high performance web server.
-- Subject: Unit nginx.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit nginx.service has failed.
--
-- The result is failed.
Jan 09 01:00:32 clients systemd[1]: Unit nginx.service entered failed state.
Jan 09 01:00:32 clients systemd[1]: nginx.service failed.
Jan 09 01:05:01 clients systemd[1]: Started Session 7789811 of user root.
-- Subject: Unit session-7789811.scope has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit session-7789811.scope has finished starting up.


I posted this the other night, I was attempting to update the kernel, don't think it worked.
http://forum.centos-webpanel.com/index.php?topic=8068.msg27597#msg27597

9
Hi,

I noticed these three were down and tried to restart them with no luck.
FTP Server, Varnish Cache Server & Nginx Reverse Proxy.

I Googled "Can't open PID file /var/run/pure-ftpd.pid (yet?) after start: Too many levels of symbolic links"

And found this post: https://forum.centos-webpanel.com/centos-7-problems/i-can't-start-ftp-server/

Following the above tutorial and trying to update the kernel but got stuck at nano /etc/default/grub

Error opening terminal: Unknown

And cat /etc/default/grub

There's no grub file at  /etc/default/

Any help appreciated


I ran these commands:

rpm --import http://www.elrepo.org/RPM-GPG-KEY-elrepo.org

rpm -Uvh https://www.elrepo.org/elrepo-release-7.0-4.el7.elrepo.noarch.rpm

yum --enablerepo=elrepo-kernel install kernel-ml -y

nano /etc/default/grub

10
SSL / Re: AutoSSL has expired on domain, can't renew it..
« on: March 16, 2019, 12:13:58 AM »
I forget exactly how I fixed it, been a while, I did reset or deleted the ssl cert and reissued it.

11
SSL / Re: Can I have a folder use http even though the domain uses https?
« on: January 17, 2019, 09:33:29 PM »
Thanks Netino,

If I knew this I wouldn't have moved the scripts to a non ssl secured domain :)
But this is handy to know thanks a lot.

12
SSL / Can I have a folder use http even though the domain uses https?
« on: January 16, 2019, 02:21:41 AM »
Hi,

I have a domain secured with https, so any http requests are forced to https.
But I have a directory on that domain that's used from something else that won't accept https requests.
I guess what I'm wondering is can I have that directory use http instead of https?
Someone said I can do it with .htacces but not sure how.

How do I achieve this?

Thanks

13
Installation / Need to update Python should I update it or install twice?
« on: December 05, 2018, 03:27:37 AM »
Hi,

I have an app to test that requires Python 3.6 but the installed versionn is 2.7.5
How can I update it or should I install the new version of Python beside version 2.7.5?

Thanks in advance.

14
FTP / Re: FTP Manager v2 no access to public_html /home/user/public_html/./
« on: November 20, 2018, 11:43:59 PM »
Ah I sorted it, I logged in as root user instead.

15
FTP / FTP Manager v2 no access to public_html /home/user/public_html/./
« on: November 20, 2018, 05:20:57 AM »
Hi,

When I create an FTP account with FTP Manager v2
I can log in but I only see .bash_profilt, .bashrc, .bash_logout,
I can't see the public_html directory or any other.

In the FTP Manager the path says /home/user/public_html/./

https://snag.gy/YkoSIu.jpg

How can I solve this?

Thanks

Pages: [1] 2 3