Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - emar

Pages: [1]
1
SSL / AutoSSL has expired on domain, can't renew it..
« on: July 02, 2018, 12:17:48 PM »
Hello,

I have an AutoSSL cert on a subdomain that has expired,
I clicked the Renew Now button under SSL Configurations,
The green popup indicated it was successful, but it hasn't renewed the cert.

I am trying to get this cert to auto update when it expires.

Also tried reload and restarting web server.

I ran the commands posted in this thread but not sure if they did anything:
http://forum.centos-webpanel.com/ssl/autorenew-ssl-is-enabled-yet-my-certificates-will-expired-after-6-days/msg12229/#msg12229

Any help appreciated.

2
I just did a fresh install on Centos 7 and I'm locked out of CWP again, the subdomain / website works.
The only thing I did on the VPS was enable firewalld and changed the default login port.

I created one user account and used subdomain.mysite.com for the domain.
I also ticked anable autossl.

Think the last thing I did was enable firewall in CWP.

When I'm in terminal I'm greeted by CWP so i guess it's running,
Restarted apache and rebooted server, no joy.

This site canít be reached
652.942.256.122 refused to connect.
Try:

Checking the connection
Checking the proxy and the firewall
ERR_CONNECTION_REFUSED

3
Informations / Will CWP work with a subdomain?
« on: March 14, 2018, 05:22:38 PM »
Hi,

Can I use a subdomain that was set up on another linux server in whm/cpanel?

Example clients.domain.com
This subdomain is pointed to my VPS.
The VPS Hostname is set to clients.domain.com
The VPS has one IP.

CWP installs fine but when I start playing with the settings,
I keep getting errors with the Hostname

Can anyone take a look at my setup in teamviewer or something?
I don't mind paying for support if I can get this setup correctly.

I created a user and added the subdomain as a domain, then enabled autossl and got locked out somehow.
So I completely rebuilt Centos 7 and enabled firewalld and changed the root login port.
I'm installing CWP again, but i need someone to have a look at my configuration.

4
I think I messed up, I'm about to delete this thing for the last time, I set user permissions then lost access to the public_html
My site loads the default page from /usr/local/apache/htdocs instead of the index.html in home/user/public_html
Eve if I delete that index file in home/user/public_html it will show Index of /webftp_simple/

I added an index.html to my home/user/public_html directory which was working fine, but not now, I'm stressed big time.

5
Hi,

Linux VPS, Centos 7, CWP 7, PHP 7.1.15

When i installed CWP 7 I logged in as root and set up free autossl on my domain which worked fine.
Every URL redirects to https, including the CWP 7 admin panel, that was showing as insecure in the address bar.

So then I was trying to get CWP 7 to redirect to https and somehow lost access to the admin panel.
I noticed that letsencrypt wasn't installed in the CWP panel, so I clicked install.

When I go to https://mysite.com:2031 I get a blank page with this message: ERR_CONNECTION_REFUSED

I can't access any website content either.
I can't access the CWP 7 admin panel at: https://mysite.com:2031

I tried turning off IPtables but no joy,

I don't know if the firewalld has anything to do with this but I get some errors:

[root@me ~]# systemctl status firewalld
* firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: enabled)
   Active: active (running) since Tue 2018-03-13 06:30:24 UTC; 54s ago
     Docs: man:firewalld(1)
 Main PID: 4862 (firewalld)
   CGroup: /system.slice/firewalld.service
           `-4862 /usr/bin/python -Es /usr/sbin/firewalld --nofork --nopid

Mar 13 06:30:25 clients firewalld[4862]: WARNING: ipset not usable, disabling ipset usage in firewall.
Mar 13 06:30:26 clients firewalld[4862]: WARNING: ICMP type 'beyond-scope' is not supported by the kernel for ipv6.
Mar 13 06:30:26 clients firewalld[4862]: WARNING: beyond-scope: INVALID_ICMPTYPE: No supported ICMP type., ignoring for run-time.
Mar 13 06:30:26 clients firewalld[4862]: WARNING: ICMP type 'failed-policy' is not supported by the kernel for ipv6.
Mar 13 06:30:26 clients firewalld[4862]: WARNING: failed-policy: INVALID_ICMPTYPE: No supported ICMP type., ignoring for run-time.
Mar 13 06:30:26 clients firewalld[4862]: WARNING: ICMP type 'reject-route' is not supported by the kernel for ipv6.
Mar 13 06:30:26 clients firewalld[4862]: WARNING: reject-route: INVALID_ICMPTYPE: No supported ICMP type., ignoring for run-time.
Mar 13 06:30:26 clients firewalld[4862]: ERROR: Failed to read file "/proc/sys/net/netfilter/nf_conntrack_helper": [Errno 2] No such file or directory: '/p...ck_helper'
Mar 13 06:30:26 clients firewalld[4862]: WARNING: Failed to get and parse nf_conntrack_helper setting
Mar 13 06:30:26 clients firewalld[4862]: WARNING: ebtables not usable, disabling ethernet bridge firewall.


Just tried this:

[root@me ~]# systemctl status cwpsrv.service
* cwpsrv.service - CentOS Web Panel service (daemon)
   Loaded: loaded (/usr/lib/systemd/system/cwpsrv.service; enabled; vendor preset: disabled)
   Active: activating (auto-restart) (Result: exit-code) since Tue 2018-03-13 07:55:06 UTC; 4s ago
  Process: 1922 ExecStartPre=/usr/local/cwpsrv/bin/cwpsrv -t (code=exited, status=1/FAILURE)

Mar 13 07:55:06 clients systemd[1]: Failed to start CentOS Web Panel servic...).
Mar 13 07:55:06 clients systemd[1]: Unit cwpsrv.service entered failed state.
Mar 13 07:55:06 clients systemd[1]: cwpsrv.service failed.
Hint: Some lines were ellipsized, use -l to show in full.

I don't know what to do and I'm in the middle of a project.

Any help appreciated  ::)

6
Installation / Centos 7 - PHP 7.1.15 where is cli and fpm located?
« on: March 11, 2018, 11:15:34 AM »
Hi,

I setup Centos 7 with CWP 7 and switched the default php version to 7.1.15.

My applications required a few extra extensions,

I'm following this tutorial to install mailparse link

I got stuck at:

CONFIGURATION:

- add extension =mailparse.so to php.ini under cli and fpm (in dynamics extensions)

sudo nano /etc/php/7.0/cli/php.ini

sudo nano /etc/php/7.0/fpm/php.ini

I can't find the path to the cli and fmp ini files. I mean etc/php doesn't exist at this location.
I mean  /etc/php/ doesn't exist.

I can see cli is running:

[root@me/]# php --version                                                                             
PHP 7.1.15 (cli) (built: Mar  9 2018 07:04:44) ( NTS )                                                       
Copyright (c) 1997-2018 The PHP Group                                                                       
Zend Engine v3.1.0, Copyright (c) 1998-2018 Zend Technologies                                               
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.2.0, C
opyright (c) 2002-2018, by ionCube Ltd.

7
Hi,

I just installed CWP on Centos 7 and I really like what I see,

When I got to VHosts Manager and select AutoSSL then Install SSL
It says: AutoSSL installation for domain clients.domain.com success!

But I see two warning above that:

Notice: Undefined variable: .(962([*66 in /usr/local/cwpsrv/htdocs/resources/admin/include/hooks.php on line 0

Notice: Undefined variable: .(962([*66 in /usr/local/cwpsrv/htdocs/resources/admin/include/hooks.php on line 0

The subdomain seems to be secure behind SSL when I use https, so I guess that's working.

Any odeas appreciated, new to thing.

Pages: [1]