Author Topic: php_selector3 Error  (Read 963 times)

0 Members and 1 Guest are viewing this topic.

Offline
***
php_selector3 Error
« on: December 01, 2018, 03:09:09 PM »
I can't install PHP 7.0/7.1/7.2 via php_selector3. Older versions <5 are installed and they are working fine.

Code: [Select]
...
Saving to: 'apcu-5.1.12.tgz'

     0K .......... .......... .......... .......... .......... 48%  300K 0s
    50K .......... .......... .......... .......... .......... 96%  607K 0s
   100K ...                                                   100% 6501G=0.2s

2018-12-01 15:57:28 (415 KB/s) - 'apcu-5.1.12.tgz' saved [105890/105890]

/usr/local/cwpsrv/htdocs/resources/conf/php-fpm_selector/external_modules/7.2/apcu.sh: line 8: /opt/alt/php-fpm72/usr/bin/phpize: No such file or directory
/usr/local/cwpsrv/htdocs/resources/conf/php-fpm_selector/external_modules/7.2/apcu.sh: line 9: ./configure: No such file or directory
make: *** No targets specified and no makefile found.  Stop.

/usr/local/cwpsrv/htdocs/resources/conf/php-fpm_selector/external_modules/7.2/apcu.sh: line 13: /opt/alt/php-fpm72/usr/bin/php-config: No such file or directory
ERROR: Missing extension file /apcu.so

Offline
*
Re: php_selector3 Error
« Reply #1 on: December 01, 2018, 09:05:14 PM »
You are installing more than one version at a time?

Offline
***
Re: php_selector3 Error
« Reply #2 on: December 01, 2018, 09:08:11 PM »
It's same with one and multiple versions at once.
« Last Edit: December 01, 2018, 09:33:30 PM by Gogo »

Offline
*
Re: php_selector3 Error
« Reply #3 on: December 03, 2018, 10:56:39 AM »
Same issue here.

Jose yo tengo el mismo error

Offline
*
Re: php_selector3 Error
« Reply #4 on: December 03, 2018, 03:59:23 PM »
Same problem :@

Offline
*
Re: php_selector3 Error
« Reply #5 on: December 04, 2018, 04:05:29 AM »
Code: [Select]
yes: standard output: Broken pipe
yes: write error
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
/usr/local/cwpsrv/htdocs/resources/conf/php-fpm_selector/external_modules/7.2/opcache.sh: line 3: /opt/alt/php-fpm72/usr/bin/php-config: No such file or directory
ERROR: Missing extension file /opcache.so
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
--2018-12-03 22:44:48--  https://pecl.php.net/get/apcu-5.1.12.tgz
Resolving pecl.php.net (pecl.php.net)... 104.236.228.160
Connecting to pecl.php.net (pecl.php.net)|104.236.228.160|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 105890 (103K) [application/octet-stream]
Saving to: 'apcu-5.1.12.tgz'

     0K .......... .......... .......... .......... .......... 48% 2.74M 0s
    50K .......... .......... .......... .......... .......... 96% 5.59M 0s
   100K ...                                                   100% 6501G=0.03s

2018-12-03 22:44:48 (3.81 MB/s) - 'apcu-5.1.12.tgz' saved [105890/105890]

/usr/local/cwpsrv/htdocs/resources/conf/php-fpm_selector/external_modules/7.2/apcu.sh: line 8: /opt/alt/php-fpm72/usr/bin/phpize: No such file or directory
/usr/local/cwpsrv/htdocs/resources/conf/php-fpm_selector/external_modules/7.2/apcu.sh: line 9: ./configure: No such file or directory
make: *** No targets specified and no makefile found.  Stop.

/usr/local/cwpsrv/htdocs/resources/conf/php-fpm_selector/external_modules/7.2/apcu.sh: line 13: /opt/alt/php-fpm72/usr/bin/php-config: No such file or directory
ERROR: Missing extension file /apcu.so
Redirecting to /bin/systemctl restart httpd.service

Build Completed
###################


Error:Can't add notification!
« Last Edit: December 04, 2018, 04:15:35 AM by thefantas »

Offline
*
Re: php_selector3 Error
« Reply #6 on: December 04, 2018, 05:46:06 PM »
I had the same issue and found in the logs that it was running out of virtual memory. I increased the servers swap file to 1024mb and I can compile successfully. Running 7.2.12.

Offline
*
Re: php_selector3 Error
« Reply #7 on: December 04, 2018, 05:56:11 PM »
I have 16GB of RAM and SWAP 8GB

Offline
***
Re: php_selector3 Error
« Reply #8 on: December 05, 2018, 04:22:15 AM »
@GTMAN That problem have to be fixed inside CWP itself and not by server modifications such as changing swap etc.
Obviously there is some memory leak while process is running.

Offline
***
Re: php_selector3 Error
« Reply #9 on: December 15, 2018, 12:32:42 PM »
v7.3    added to the selector but still no fix for the problem above.

Offline
*
Re: php_selector3 Error
« Reply #10 on: January 02, 2019, 10:27:17 AM »
Same problem here, I can't switch to a 7.X version

Offline
***
Re: php_selector3 Error
« Reply #11 on: January 02, 2019, 04:45:45 PM »
I have temporarly fixed this by disabling xpm-dir in Options list before building/rebuilding 7.x versions.

And still, that have to be fixed inside CWP because that php builder script has a memory leak looks like.
« Last Edit: January 02, 2019, 04:49:02 PM by Gogo »

Offline
*****
Re: php_selector3 Error
« Reply #12 on: January 06, 2019, 09:16:33 AM »
probably you've memory related error on your server/node.

Offline
***
Re: php_selector3 Error
« Reply #13 on: January 06, 2019, 06:47:36 PM »
That't not related to my server, it's a CWP problem.

I've tested that on 10+ servers (different specs) and every single one of them had same problem. Also I am not the only one who have that problem. Just check the rest of the forum how many people faced it.

Offline
*****
Re: php_selector3 Error
« Reply #14 on: January 07, 2019, 09:00:38 AM »
That't not related to my server, it's a CWP problem.

I've tested that on 10+ servers (different specs) and every single one of them had same problem. Also I am not the only one who have that problem. Just check the rest of the forum how many people faced it.
provide the full log