Author Topic: Error 503 for WordPress on PHP-FPM 7.3.4  (Read 928 times)

0 Members and 1 Guest are viewing this topic.

Offline
***
Error 503 for WordPress on PHP-FPM 7.3.4
« on: April 29, 2019, 05:29:09 AM »
I've built PHP 7.3.4 and configured a test wordpress site webserver to use it but I get a 503 error.
I've tried with other sites - and the same result.
I've tried disabling plugins, but the error is still there.


Anyone managed to run Wordpress on PHP 7.3.4?

Offline
***
Re: Error 503 for WordPress on PHP-FPM 7.3.4
« Reply #1 on: April 29, 2019, 07:57:38 AM »
Ok, I've made some more tests. I've installed 7.3.3 and got the same 503 error.
Eventually I've installed 7.3.0 and got the same.

Any idea?
« Last Edit: April 29, 2019, 08:06:13 AM by ring_c »

Offline
**
Re: Error 503 for WordPress on PHP-FPM 7.3.4
« Reply #2 on: April 29, 2019, 10:28:18 AM »
Donít forget to fix the permission
Go to User Account >> Fix Permission >> Select the user

Offline
***
Re: Error 503 for WordPress on PHP-FPM 7.3.4
« Reply #3 on: April 29, 2019, 10:53:20 AM »
Donít forget to fix the permission
Go to User Account >> Fix Permission >> Select the user
Tried that already. Didn't help.

Offline
**
Re: Error 503 for WordPress on PHP-FPM 7.3.4
« Reply #4 on: April 29, 2019, 03:20:19 PM »
Check the error log and share with us
Code: [Select]
# tail -f /usr/local/apache/domlogs/domain.com.error.log
are you using apache only OR NGINX+php-fpm+virnish ?

Offline
***
Re: Error 503 for WordPress on PHP-FPM 7.3.4
« Reply #5 on: April 29, 2019, 03:27:45 PM »
There you go:

Code: [Select]
[Mon Apr 29 18:25:18.935259 2019] [proxy:error] [pid 29643:tid 139770902599424] (2)No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /opt/alt/php-fpm73/usr/var/sockets/wpkcf.sock (*) failed
[Mon Apr 29 18:25:18.935382 2019] [proxy_fcgi:error] [pid 29643:tid 139770902599424] [client xxx.253.221.xxx:57924] AH01079: failed to make connection to backend: httpd-UDS


By the way it's:
nginx -> varnish -> apache -> php-fpm

Offline
**
Re: Error 503 for WordPress on PHP-FPM 7.3.4
« Reply #6 on: April 30, 2019, 06:09:20 AM »
Will you follow below the process again ?
>>Goto WebServer Settings >> WebServer Domain Conf >> Select a UserName >> username >> nginx -> varnish -> apache -> php-fpm
>>Now Fix the permission : User Accounts >> Fix Permissions

Restart if service is enabled (depends on your version)
Code: [Select]
# /bin/systemctl reload php-fpm71.service 

Restart all the services from CWP dashboard. Don't forget to share the log again with details .

Offline
***
Re: Error 503 for WordPress on PHP-FPM 7.3.4
« Reply #7 on: April 30, 2019, 06:23:42 AM »
I assume you mean:
Code: [Select]
# /bin/systemctl reload php-fpm73.service 
Correct?

Offline
**
Re: Error 503 for WordPress on PHP-FPM 7.3.4
« Reply #8 on: April 30, 2019, 06:29:00 AM »
yes

Offline
***
Re: Error 503 for WordPress on PHP-FPM 7.3.4
« Reply #9 on: April 30, 2019, 06:34:09 AM »
When executing:
Code: [Select]
# /bin/systemctl reload php-fpm73.service

I get:

Code: [Select]
Job for php-fpm73.service invalid
I've followed all your steps (although already done them all except for the reload of php-fpm73. I get the same result and same error log. But I think we now understand there's an issue with php-fpm73. Unfortunately, I don't know what the issue is.

Offline
***
Re: Error 503 for WordPress on PHP-FPM 7.3.4
« Reply #10 on: April 30, 2019, 06:49:26 AM »
Trying to compare between /opt/alt/php-fpm73/ and /opt/alt/php-fpm72/ I've found out that /opt/alt/php-fpm73/usr/var/sockets/ is empty, while /opt/alt/php-fpm73/usr/var/sockets/ has .sock files for wach user.

Could that help?
« Last Edit: April 30, 2019, 06:51:24 AM by ring_c »

Offline
**
Re: Error 503 for WordPress on PHP-FPM 7.3.4
« Reply #11 on: April 30, 2019, 08:00:58 AM »
If missing , then create those sock file as per your need

Code: [Select]
[root@host sockets]# cd /opt/alt/php-fpm73/usr/var/sockets

[root@host sockets]# ll

srw-r----- 1 cwpsvc   cwpsvc 0 Apr 30 11:48 cwpsvc.sock
srw-rw---- 1 nobody   nobody 0 Apr 30 11:48 nobody.sock
srw-rw---- 1 realmart nobody 0 Apr 30 11:48 realmart.sock

Offline
***
Re: Error 503 for WordPress on PHP-FPM 7.3.4
« Reply #12 on: April 30, 2019, 08:09:28 AM »
Created, but still doesn't work.
Also, still same error when trying to reload php-fpm73:


Code: [Select]
Job for php-fpm73.service invalid

Offline
***
Re: Error 503 for WordPress on PHP-FPM 7.3.4
« Reply #13 on: April 30, 2019, 08:27:04 AM »
Oh damn! It works now!!!
All I did was going to the PHP-FPM selector screen in the GUI panel of CWP - Clicking the yellow recycle icon for reload, didn't work and gave again the error above. But when I clicked the Green right arrow icon for starting PHP-FPM73 - guess what! It worked!

Now to the question - why isn't the service automatically starting after compiling the php version?


The ssh command is:
Code: [Select]
/bin/systemctl start php-fpm73.servce

Offline
**
Re: Error 503 for WordPress on PHP-FPM 7.3.4
« Reply #14 on: April 30, 2019, 09:34:05 AM »
Code: [Select]
# /bin/systemctl enable php-fpm73.servce