Author Topic: Upgrade php 5.6 to version 5.6.29  (Read 2718 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Upgrade php 5.6 to version 5.6.29
« on: January 05, 2017, 06:40:51 AM »
CWP use php 5.6.16 which is more than 1 year old - released on 01 Oct 2015. Update is quite easy. Edit file /usr/local/src/php-5.6.sh like this :
Code: [Select]
#version=5.6.14
version=5.6.29
phpsource="http://de1.php.net/distributions/php-$version.tar.bz2"
#phpsource="http://dl1.centos-webpanel.com/files/php/selector/php-$version.tar.bz2"
I used DE mirror because my server is located in Germany, but feel free to use any other near to you.

After that install new php version with:
Code: [Select]
sh /usr/local/src/php-5.6.shI highly suggest CWP team to update php version - there is a lot CVE fixes between 5.6.14 and 5.6.29.
“Would you tell me, please, which way I ought to go from here?”
“That depends a good deal on where you want to get to,” said the Cat.
“I don’t much care where–” said Alice.
“Then it doesn’t matter which way you go,” said the Cat.
Neo2SHYAlien's Blog

Offline
*****
Re: Upgrade php 5.6 to version 5.6.29
« Reply #1 on: January 05, 2017, 07:02:07 AM »
php versions are regularly updated in cwp

Offline
*
Re: Upgrade php 5.6 to version 5.6.29
« Reply #2 on: January 05, 2017, 07:10:31 AM »
php versions are regularly updated in cwp

What is regularly because the version in the switcher is 5.6.14 ?
“Would you tell me, please, which way I ought to go from here?”
“That depends a good deal on where you want to get to,” said the Cat.
“I don’t much care where–” said Alice.
“Then it doesn’t matter which way you go,” said the Cat.
Neo2SHYAlien's Blog

Offline
*****
Re: Upgrade php 5.6 to version 5.6.29
« Reply #3 on: January 06, 2017, 04:06:19 PM »
php versions are regularly updated in cwp

What is regularly because the version in the switcher is 5.6.14 ?
what cwp version you're using ?

Offline
*
Re: Upgrade php 5.6 to version 5.6.29
« Reply #4 on: January 06, 2017, 04:10:15 PM »
what cwp version you're using ?

 CWP version: 0.9.8.132 with auto updates enabled :)
“Would you tell me, please, which way I ought to go from here?”
“That depends a good deal on where you want to get to,” said the Cat.
“I don’t much care where–” said Alice.
“Then it doesn’t matter which way you go,” said the Cat.
Neo2SHYAlien's Blog

Offline
*****
Re: Upgrade php 5.6 to version 5.6.29
« Reply #5 on: January 07, 2017, 03:04:12 AM »
use this commands to build the php :)

Code: [Select]
mkdir -p /usr/local/php-5-6
cd /usr/local/php-5-6
wget http://php.net/distributions/php-5.6.29.tar.gz
tar zxvf php-5.6.29.tar.gz
cd php-5.6.29
./configure --with-zlib --enable-soap --enable-exif --with-config-file-path=/usr/local/php --with-config-file-scan-dir=/usr/local/php/php.d --enable-phar --enable-bcmath --enable-calendar --with-curl --with-iconv --with-mysql --with-mysqli --with-mysql=mysqlnd --with-mysqli=mysqlnd --with-mcrypt --with-gettext --with-xsl --with-xmlrpc --with-pdo-mysql=mysqlnd --enable-posix --enable-ftp --with-openssl --enable-mbstring --with-kerberos --with-xsl --with-bz2 --enable-sockets --enable-zip --with-gd --with-jpeg-dir --enable-gd-native-ttf --with-freetype-dir --with-pcre-regex --libdir=/usr/lib64 --with-mysql-sock=/var/lib/mysql/mysql.sock
make && make install
[code]

Offline
*
Re: Upgrade php 5.6 to version 5.6.29
« Reply #6 on: January 07, 2017, 06:35:55 AM »
Maybe I wasn't clear enough and misled you. This version is installed as alternative version via the switcher, not as default php version.
“Would you tell me, please, which way I ought to go from here?”
“That depends a good deal on where you want to get to,” said the Cat.
“I don’t much care where–” said Alice.
“Then it doesn’t matter which way you go,” said the Cat.
Neo2SHYAlien's Blog

Offline
*
Re: Upgrade php 5.6 to version 5.6.29
« Reply #7 on: March 08, 2017, 07:53:32 AM »
Does anyone have an update for the latest version of CWP, it seems in the latest version, the file /usr/local/src/php-5.6.sh doesn't exist any longer and I need PHP 5.6.30 in my switcher, rather than 5.6.14.

That or if anyone has resolved on how to upgrade the switcher version from 5.6.14 to 5.6.30 in the latest version of CWP, please reply..

Thank you.

Offline
*
Re: Upgrade php 5.6 to version 5.6.29
« Reply #8 on: March 08, 2017, 08:00:17 AM »
Does anyone have an update for the latest version of CWP, it seems in the latest version, the file /usr/local/src/php-5.6.sh doesn't exist any longer and I need PHP 5.6.30 in my switcher, rather than 5.6.14.

That or if anyone has resolved on how to upgrade the switcher version from 5.6.14 to 5.6.30 in the latest version of CWP, please reply..

Thank you.

I'm still waiting for upgrade scripts for the new version. For older  0.9.8.153 version this fix works fine, before few days I upgrade my php to 5.6.30 :)

p.s After first compilation CWP create needed scripts under /usr/local/src/ ;)
p.s2 but for some reason CWP remove shell scripts here is a link for the original script from 0.9.8.189  CWP
« Last Edit: March 08, 2017, 08:53:00 AM by Neo2SHYAlien »
“Would you tell me, please, which way I ought to go from here?”
“That depends a good deal on where you want to get to,” said the Cat.
“I don’t much care where–” said Alice.
“Then it doesn’t matter which way you go,” said the Cat.
Neo2SHYAlien's Blog

Offline
*
Re: Upgrade php 5.6 to version 5.6.29
« Reply #9 on: March 08, 2017, 08:28:53 AM »
soon there will be released scripts for centos 6 cwp version 153 upgrade and after that upgrade you will be able to install any php version via new friendly php switcher.
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: Upgrade php 5.6 to version 5.6.29
« Reply #10 on: March 11, 2017, 05:47:34 AM »
I'm currently using CWP7pro.admin (latest version); will this upgrade apply to CWP7?

Thanks!

soon there will be released scripts for centos 6 cwp version 153 upgrade and after that upgrade you will be able to install any php version via new friendly php switcher.

Offline
*
Re: Upgrade php 5.6 to version 5.6.29
« Reply #11 on: March 21, 2017, 07:34:27 AM »
Neo2SHYAlien:
Thank you the link, I was able to update my switcher version of PHP from 5.6.14 to 5.6.30, in addition, compile modules for memcache, opcache and imagemagick; I have to run each additional on separate builds by using modified scripts, it's a kludge, but it works, if it could only be streamlined, that would be a plus.

Speaking of the PHP module memcache, unfortunately I was not able to compile memcached, despite repeated attempts, so for the time being I'm using the server daemon 'memcached' with PHP module memcache, although was I understand, it's not ideal.

In any event, again, thank you!

Does anyone have an update for the latest version of CWP, it seems in the latest version, the file /usr/local/src/php-5.6.sh doesn't exist any longer and I need PHP 5.6.30 in my switcher, rather than 5.6.14.

That or if anyone has resolved on how to upgrade the switcher version from 5.6.14 to 5.6.30 in the latest version of CWP, please reply..

Thank you.

I'm still waiting for upgrade scripts for the new version. For older  0.9.8.153 version this fix works fine, before few days I upgrade my php to 5.6.30 :)

p.s After first compilation CWP create needed scripts under /usr/local/src/ ;)
p.s2 but for some reason CWP remove shell scripts here is a link for the original script from 0.9.8.189  CWP

Offline
*
Re: Upgrade php 5.6 to version 5.6.29
« Reply #12 on: March 21, 2017, 07:36:27 AM »
Any ETA on those updated scripts and if they'll be CWP7 compatible? I wouldn't mind testing on my smaller VPS.

LMK,
Thanks!


soon there will be released scripts for centos 6 cwp version 153 upgrade and after that upgrade you will be able to install any php version via new friendly php switcher.

Offline
*
Re: Upgrade php 5.6 to version 5.6.29
« Reply #13 on: March 21, 2017, 08:01:20 AM »
Neo2SHYAlien:
Thank you the link, I was able to update my switcher version of PHP from 5.6.14 to 5.6.30, in addition, compile modules for memcache, opcache and imagemagick; I have to run each additional on separate builds by using modified scripts, it's a kludge, but it works, if it could only be streamlined, that would be a plus.

Speaking of the PHP module memcache, unfortunately I was not able to compile memcached, despite repeated attempts, so for the time being I'm using the server daemon 'memcached' with PHP module memcache, although was I understand, it's not ideal.

In any event, again, thank you!

You are very welcome :)
“Would you tell me, please, which way I ought to go from here?”
“That depends a good deal on where you want to get to,” said the Cat.
“I don’t much care where–” said Alice.
“Then it doesn’t matter which way you go,” said the Cat.
Neo2SHYAlien's Blog