Author Topic: Beta Backup - SFTP  (Read 783 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Beta Backup - SFTP
« on: November 30, 2023, 07:39:04 PM »
I've recently setup an SFTP server which I want CWP to connect to in order to offsite backups.  When I try create the Backup Destination and test the connection, I get a "Something went wrong" error.  The error does not provide any further details beyond something went wrong.

I have tested the SFTP server successfully using Forklift on my Mac, and I have other programs successfully backing up to the SFTP server without issue.  CWP will not successfully test the connection, and I have no idea what the actual error is.

Anyone have any ideas on where to start?

Additional Info:  I recently changed which SFTP server I was using, however kept the same user account info, server name, etc.  Is it possible that CWP has cached SSH entries which are now generating the error when trying to access the new server?
« Last Edit: November 30, 2023, 07:57:44 PM by UnpickedUsername »

Offline
****
Re: Beta Backup - SFTP
« Reply #1 on: December 01, 2023, 12:17:46 AM »
please try to sftp from the server using your credentials using an ssh console and report back what it says.
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: Beta Backup - SFTP
« Reply #2 on: December 01, 2023, 01:14:43 AM »
Direct from the server console, after entering the password I get the following:

Code: [Select]
PTY allocation request failed on channel 0
shell request failed on channel 0

Offline
****
Re: Beta Backup - SFTP
« Reply #3 on: December 01, 2023, 01:21:55 AM »
This particular error shows that there is a misconfiguration of the host server, not with the sftp client.   Do you have root access to the host server, or is it something like an aws server?
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: Beta Backup - SFTP
« Reply #4 on: December 01, 2023, 11:53:26 PM »
I do have access.  I'm running SFTPgo in a docker container.  SFTPgo is working fine with a completely different server connecting in and uploading backups, but CWP has issue.

Offline
****
Re: Beta Backup - SFTP
« Reply #5 on: December 02, 2023, 02:21:55 AM »
I would go through the sftpgo error log and look for hints.   the sftp program on CentOS is what CWP uses, so seeing as your getting an error from shell, CWP won't work until you can figure out what's going wrong between the sftp client and your sftpgo server.
Google Hangouts:  rcschaff82@gmail.com