Author Topic: Private nameserver/glue record config  (Read 393 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Private nameserver/glue record config
« on: December 04, 2023, 05:29:35 PM »
Hi Guys,

So I'm pretty new to CWP, but I have a basic grasp of dns, just struggling with a few of the settings, so let me start from the beggining.

3 weeks ago I asked my registrar to update my glue record so I could run my own nameservers, they did this but this never propogated and the reason behind that was dynamic i.p (I didn't understand at the time as my router had dyndns) but fast forward 3 weeks I change ISP and get a static IP, prior to finding CWP, I messed about with other panels learning little by little along the way, a few days ago i installed CWP for the 1st time but removed it as it wasn't playing nicely with MediaCP, at that point I knew very little of CWP so i just ploughed ahead, remember prior to this I was still waiting for ywrserver.uk to propogate but as I know know it never would have done as it wasn't on a physical server so this last install I again tried with ywrserver.uk and it is propogating at last!! BUT there's warnings in leafdns that i need to correct such as the SOA record.

So
will the soa records update automatically?

can anyone point me in the right direction of what records should now be updated from my end in CWP.

if you need screen shots/logs please let me know if you need logs please tell me the location of these.

P.s Absolutelyloving this software, steep learning curve but enjoying it.

Offline
****
Re: Private nameserver/glue record config
« Reply #1 on: December 05, 2023, 12:18:54 AM »
SOA records are set by YOUR NS1 and NS2, and should reflect your first nameserver as the SOA.

Checking your domain, it looks like everything propagated properly now.

« Last Edit: December 05, 2023, 12:36:36 AM by rcschaff »
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: Private nameserver/glue record config
« Reply #2 on: December 11, 2023, 11:42:48 AM »
Hi Guys,

So I'm pretty new to CWP, but I have a basic grasp of dns, just struggling with a few of the settings, so let me start from the beggining.

3 weeks ago I asked my registrar to update my glue record so I could run my own nameservers, they did this but this never propogated and the reason behind that was dynamic i.p (I didn't understand at the time as my router had dyndns) but fast forward 3 weeks I change ISP and get a static IP, prior to finding CWP, I messed about with other panels learning little by little along the way, a few days ago i installed CWP for the 1st time but removed it as it wasn't playing nicely with MediaCP, at that point I knew very little of CWP so i just ploughed ahead, remember prior to this I was still waiting for ywrserver.uk to propogate but as I know know it never would have done as it wasn't on a physical server so this last install I again tried with ywrserver.uk and it is propogating at last!! BUT there's warnings in leafdns that i need to correct such as the SOA record.

So
will the soa records update automatically?

can anyone point me in the right direction of what records should now be updated from my end in CWP.

if you need screen shots/logs please let me know if you need logs please tell me the location of these.

P.s Absolutelyloving this software, steep learning curve but enjoying it.

I am busy with testing of CWP for the last 12+ months and it's been going great.

From what I gathered - You are setting up an experimental machine with port forwarding and a CWP appliance.

Have you two or more static IPs attached to your ISP endpoint? Most DNS registries requires at least two or more IP addresses as glue for your DNS service. Also, you would need a highly configurable router to facilitate multiple outbound routes to labeled with each respected IP address. DNS will not work properly if your DNS answering suddenly comes from a different IP address and will cause unsolvable errors. Only one of the two IP addresses will be your reply IP address as well as your mail origin IP address. Make sure to specify a private IP and Public IP in your CWP config page.

Let me know if you need more help.

LJB