Author Topic: Default Page Displayed for all domains  (Read 40438 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Re: Default Page Displayed for all domains
« Reply #30 on: April 28, 2015, 02:33:52 AM »
i have following settings
188.215.77.24 is my external ip(internet provider)
192.168.1.130 is my lan ip

vhosts

Code: [Select]
# vhost_start kyme32.ro
<VirtualHost 188.215.77.24:80>
ServerName kyme32.ro
ServerAlias www.kyme32.ro
ServerAdmin kyme32@yahoo.com
DocumentRoot "/home/kyme32/public_html"
ScriptAlias /cgi-bin/ "/home/kyme32/public_html/cgi-bin/
#
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/kyme32/kyme32.ro/*.conf

<IfModule mod_suexec.c>
        SuexecUserGroup kyme32 kyme32
</IfModule>

<IfModule mod_suphp.c>
        suPHP_UserGroup kyme32 kyme32
        suPHP_ConfigPath /home/kyme32
</IfModule>

<Directory "/home/kyme32/public_html">
        AllowOverride All
</Directory>

</VirtualHost>
# vhost_end kyme32.ro

# vhost_start cs.kyme32.ro
<VirtualHost 188.215.77.24:80>
ServerName cs.kyme32.ro
ServerAlias www.cs.kyme32.ro
ServerAdmin kyme32@yahoo.com
DocumentRoot "/home/kyme32/public_html/cs_kyme32_ro"
ScriptAlias /cgi-bin/ /home/kyme32/public_html/cs_kyme32_ro/cgi-bin/
#
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/kyme32/cs.kyme32.ro/*.conf

<IfModule mod_suexec.c>
        SuexecUserGroup kyme32 kyme32
</IfModule>

<IfModule mod_suphp.c>
        suPHP_UserGroup kyme32 kyme32
</IfModule>

<Directory "/home/kyme32/public_html/cs_kyme32_ro">
        AllowOverride All
</Directory>

</VirtualHost>
# vhost_end cs.kyme32.ro

they are all rebuilded and default template

under accounts the ip address for domain kyme32.ro is 188.215.77.24

NS1: ns1.kyme32.ro | IP:188.215.77.24 [Change]
NS2: ns2.kyme32.ro | IP:188.215.77.24 [Change]
Server IP: 192.168.1.130 | 192.168.1.130
Shared IP: 188.215.77.24 [Change]
Hostname: localhost.kyme32.ro [Change]

NS are configured on website tld as in cwp

/var/named/kyme32.ro.db
Code: [Select]
; Panel %version%
; Zone file for kyme32.ro
$TTL 14400
kyme32.ro.      86400        IN      SOA     ns1.kyme32.ro. kyme32.yahoo.com. (
         2013071600      ; serial, todays date+todays
                86400           ; refresh, seconds
          7200            ; retry, seconds
            3600000         ; expire, seconds
           86400 )         ; minimum, seconds

kyme32.ro. 86400 IN NS ns1.kyme32.ro.
kyme32.ro. 86400 IN NS ns2.kyme32.ro.

kyme32.ro. IN A 188.215.77.24

localhost.kyme32.ro. IN A 127.0.0.1

kyme32.ro. IN MX 0 kyme32.ro.

mail IN CNAME kyme32.ro.
www IN CNAME kyme32.ro.
ftp IN CNAME kyme32.ro.
; Add additional settings below this line
ns1.kyme32.ro. 14400 IN A 188.215.77.24

ns2.kyme32.ro. 14400 IN A 188.215.77.24

cs     14400   IN      A       188.215.77.24 ; #subdomain cs

i am behind a router, what has dmz to 192.168.1.130, every port pointing to server
now can anybody please tell me why my domain point to default page and that's in /usr/local/apache/htdocs/index.html

the install of centos is made in minimal desktop version 6.6

the yum list installed | grep httpd returns
Code: [Select]
httpd-tools.x86_64    2.2.15-39.el6.centos
any hints what can i do to get it working and don't return again to microsux?

Offline
***
Re: Default Page Displayed for all domains
« Reply #31 on: April 28, 2015, 10:43:16 AM »
Hi

do you have Varnish enabled ?

Offline
*
Re: Default Page Displayed for all domains
« Reply #32 on: April 28, 2015, 05:11:25 PM »
i didn't installed it at first but after i've installed it, same result

there are the settings of it
Code: [Select]
Apache IP (recommended: your Shared IP, or 127.0.0.1): 188.215.77.24
Apache Port (recommended: 82): 80
Varnish IP (recommended: Shared IP or all): all
Varnish Port (recommended: 80): 6081
Varnish Storage Size (recommended: 1G): 1G

netstat info
Code: [Select]
Netstat info
tcp        0      0 :::80                       :::*                        LISTEN      2319/httpd         
tcp        0      0 0.0.0.0:6081                0.0.0.0:*                   LISTEN      2366/varnishd       
tcp        0      0 127.0.0.1:6082              0.0.0.0:*                   LISTEN      2363/varnishd       
tcp        0      0 :::6081                     :::*                        LISTEN      2366/varnishd       

if anyone can tell me what's wrong please let me know, i will share the root pass with support team if anybody is good willing to take a look at it and maybe make it working for me and for every user with this problem

Re: Default Page Displayed for all domains
« Reply #33 on: May 01, 2015, 03:35:18 PM »
Better contact your server provider.

Offline
*
Re: Default Page Displayed for all domains
« Reply #34 on: May 24, 2015, 02:44:11 PM »
Hi

I've got the same issue, running on MICROSOFT AZURE. Followed all the steps as posted throughout this thread. Nothing fixed it.

public ip: 137.116.193.163 (CWP automatically filled it in as the "shared ip")
server ip: 10.2.0.4 (but shows as "default" next to "shared ip"

Running CENTOS 6.5 vanilla install. I've reinstalled a couple of times modifying items to try to get it to work but couldn't.

I added one account "account1" with one domain "domain1.com"
When I open up that domain1.com it shows the HTTP Server Test Page (even if i remove the /USERNAME/Public_html/index.html)

Code: [Select]
# vhost_start domain1.com
<VirtualHost 137.116.193.163:80>
ServerName domain1.com
ServerAlias www.domain1.com
ServerAdmin jeevadotnet@mail.com
DocumentRoot "/home/user1/public_html"
ScriptAlias /cgi-bin/ "/home/user1/public_html/cgi-bin/
#
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/user1/domain1.com/*.conf

<IfModule mod_suexec.c>
        SuexecUserGroup user1 user1
</IfModule>

<IfModule mod_suphp.c>
        suPHP_UserGroup user1 user1
        suPHP_ConfigPath /home/user1
</IfModule>

<Directory "/home/user1/public_html">
        AllowOverride All
</Directory>

</VirtualHost>
# vhost_end domain1.com

user1 & domain1.com = example
Regards
« Last Edit: May 24, 2015, 02:47:02 PM by jeeva »

Offline
*
Re: Default Page Displayed for all domains
« Reply #35 on: June 03, 2015, 04:05:05 AM »
Same problem here. When I try to setup a domain on different IP it always shows the default page...  >:(

Offline
*
Re: Default Page Displayed for all domains
« Reply #36 on: June 16, 2015, 04:00:44 PM »
I had the same problem and the problem had to do with Varnish.

It was solved when I finally saw the "If you have more than one IP on your server then click here to use Varnish Multiple IP." option.

This should help IF you have multiple IP's on your server AND are using Varnish.

Offline
*
Re: Default Page Displayed for all domains
« Reply #37 on: June 16, 2015, 05:29:05 PM »
Hmm, now I don't understand it anymore...

With the above setup my domains were working, both the one on shared and dedicated IP, but for some reason my subdomain was simply showing the content of the main domain...

I tried all different Varnish settings and nothing worked, but in the end I went back to DISABLE Varnish multiple IP option and after many times saving the exact same settings, all of a sudden all domains + subdomain are working...

I have noticed in the past few months using the panel that many times the Varnish settings don't get saved properly and that you have to do the same thing 3 or 4 times before the settings are saved correctly, this time it looked to be the same.

So at some level I am happy that all is working now, but since I don't know what actually caused all my misery and the misery from other posters, I cannot help but feel that Varnish needs to be looked into more as it always gives problems, in my case most likely due to not saving settings correctly.

Hope you can fix it in some newer version.

Offline
*
Re: Default Page Displayed for all domains
« Reply #38 on: July 13, 2015, 03:23:43 PM »
I went to CWP Settings and changed my Default IP to * and the restarted Apache and now my other sites work.

Only took me like 8 hours and 4 complete rebuilds to figure that out...  :-\

Offline
*
Re: Default Page Displayed for all domains
« Reply #39 on: July 13, 2015, 05:29:20 PM »
I have the same problem here and I've tried all the solutions proposed since the first message post.

The only thing that changed was when I pointed to the vhost *: 80 instead of "ip": 80.

Before the default page did not display the image and centos_webpanel_logo.png now typically displays.

However, in any field I keep seeing the default page instead of the files contained in public_html.

I'm installing on a EC2 in AWS and the installation correctly recognized the public ip.

Offline
*
Re: Default Page Displayed for all domains
« Reply #40 on: July 13, 2015, 06:43:02 PM »
new WebServer selector should have this issue resolved as there is no any-more varnish and nginx separated modules.
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: Default Page Displayed for all domains
« Reply #41 on: September 11, 2015, 03:06:41 AM »
Server IP: xxx.31.33.132 | ip-xxx-31-33-132.sa-east-1.compute.internal
Shared IP: xxx.94.229.218

// Account 1
<VirtualHost xxx.31.33.132:80>
ServerName domain.com

// Account 2
<VirtualHost xxx.31.33.132:80>
ServerName subdomain.domain.com


Problem: subdomain shows the main page of the domain.


Offline
*****
Re: Default Page Displayed for all domains
« Reply #42 on: September 11, 2015, 06:09:30 PM »
Hello.

Check the DocumentRoot for the domain and subdomain it must be different.

Offline
*
Re: Default Page Displayed for all domains
« Reply #43 on: September 18, 2015, 05:40:56 PM »
Solution:

Go: Apache Configuration ( index.php?module=file_editor&file=/usr/local/apache/conf/httpd.conf )


#Virtual hosts
#Include conf/extra/httpd-vhosts.conf


Remove # only for Include....

And Restart Apache.

: )

Offline
*****
Re: Default Page Displayed for all domains
« Reply #44 on: September 20, 2015, 08:41:06 AM »
Solution:

Go: Apache Configuration ( index.php?module=file_editor&file=/usr/local/apache/conf/httpd.conf )


#Virtual hosts
#Include conf/extra/httpd-vhosts.conf


Remove # only for Include....

And Restart Apache.

: )

CWP does not using conf/extra/httpd-vhosts.conf