Author Topic: Default Page Displayed for all domains  (Read 43836 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Re: Default Page Displayed for all domains
« Reply #45 on: September 25, 2015, 06:09:09 AM »
I too faced this problem for hours and in my case it was so simple. In the CWP settings I had put in my public IP address. Put the one that it defaults to, probably 172.xxx.xxx.xxx and all was fixed. You will have to edit your user(s) too so they have this IP address, rebuild virtual hosts and for me anyway the web page was no longer the default one, but the one in the users public directory. I preferred to delete the user and add them again as the option for the 172...IP for users only appeared after I did

I have just looked back on all the posts in this thread and all the server IPs that are listed (many are not)  are either public, or the one given to your PC by your routers (eg 192.xxx.xxx.xxx). Both of these will give the wretched default page for all your domains. There is a third IP to consider, the one that apache creates which is then shares, probably 172.....

So in my case

NS1: a.dxmx.com | IP:78.12.123.232 [Change] Public
NS2: b.dxmx.com | IP:78.12.123.232 [Change] Public
Server IP: 172.31.1.100 | CentOS-67-64-minimal apache IP
Shared IP: 172.31.1.100 [Change] apache IP

For those who have their machines on a router, and I am guessing here, you  will need to forward the ports in the router to the 192.xxx of the machine hosting the webpanel, but that is a completely different issue.

In both cases all domains should point to single public IP address as set with your domain providor (the nameservers) and webpanel/apache will share an internal IP it made up all on its own.

BTW I took out all other suggestions in this thread on the basis that the I think the best config is the one the coders provided in the first place.

Hope this helps.

« Last Edit: September 25, 2015, 06:33:39 AM by charliefinale »

Offline
*
Re: Default Page Displayed for all domains
« Reply #46 on: October 17, 2015, 03:39:10 PM »
/usr/local/apache/conf/httpd.conf
Add
Code: [Select]
NameVirtualHost *:80 -> resolves apache default host to an adaptive address
Comment out
Code: [Select]
#DocumentRoot "/usr/local/apache/htdocs" -> Skips apache default htdocs and default to Virtual Host instance

Apache virtual host template
Replace VirtualHost instance ip with *
Code: [Select]
<VirtualHost *:%domain_port%> -> resolves to common address

Rebuild VirtualHost -> Restart apache [httpd]

« Last Edit: October 17, 2015, 03:46:31 PM by xHalloweenx »

Offline
*
Re: Default Page Displayed for all domains
« Reply #47 on: December 20, 2015, 02:34:46 PM »
Hi every body
I,m a new  on cwp, and have a big problem
i install my cwp then set the shared ip and Setup nameserversand create new account (USER) by domain for example (TEST.COM)
when i open my address insted open my "public-html" folder it,s related to "/usr/local/apache/htdocs/" folder
i " Rebuild Apache vHosts" but problem is still
how can i fix it?



Offline
*
Re: Default Page Displayed for all domains
« Reply #48 on: January 03, 2016, 02:53:20 PM »
I have just experienced this problem.
Thanks to @charliefinale. Your method resolved my problem.

To sum up, I deleted the user and recreate it with local IP (192.168.1.xxx) address rather than shared global IP address.
Global "index.html" (it is a welcome page) in "/usr/local/apache/htdocs" changed to user's index.html (it is a welcome page too) in user's public_html directory.

In addition, take into consideration that restart Apache WebServer in Services Status.

Offline
***
Re: Default Page Displayed for all domains
« Reply #49 on: January 23, 2016, 07:52:45 AM »
/usr/local/apache/conf/httpd.conf
Add
Code: [Select]
NameVirtualHost *:80 -> resolves apache default host to an adaptive address
Comment out
Code: [Select]
#DocumentRoot "/usr/local/apache/htdocs" -> Skips apache default htdocs and default to Virtual Host instance

Apache virtual host template
Replace VirtualHost instance ip with *
Code: [Select]
<VirtualHost *:%domain_port%> -> resolves to common address

Rebuild VirtualHost -> Restart apache [httpd]

I faced this problem too, follow your post, can fix problem.
Only in my cwp, file must edited is "/usr/local/apache/conf/sharedip.conf"

Offline
*
Re: Default Page Displayed for all domains
« Reply #50 on: January 25, 2016, 11:27:22 PM »
using local ip isn't necessary anymore since you can enable NAT-ed mod in the CWP settings.
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: Default Page Displayed for all domains
« Reply #51 on: March 03, 2016, 01:55:24 AM »
I have this issue and none of these fixes work. This is not a fresh install.. please help. I have tired rebuilding the virtual host. When I click Apache Stautus this is what I get   
Quote
Not Found

   The requested URL /server-status was not found on this server.


My Netstat info gives me this:
Quote
Netstat info
tcp        0      0 :::80                       :::*     

Offline
*
Re: Default Page Displayed for all domains
« Reply #52 on: April 30, 2016, 09:46:13 AM »
I went to CWP Settings and changed my Default IP to * and the restarted Apache and now my other sites work.

Only took me like 8 hours and 4 complete rebuilds to figure that out...  :-\


This worked for me :) But this will create an error in named. Like this

Checking DNS Zone Record for Domain: yourdomain.ltd   
Checking Zone File: /var/named/yourdomain.ltd.db

dns_rdata_fromtext: /var/named/yourdomain.ltd.db:15: near '*': bad dotted quad
zone yourdomain.ltd/IN: loading from master file /var/named/yourdomain.ltd.db failed: bad dotted quad
zone yourdomain.ltd/IN: not loaded due to errors.

But if your'e behind a router NAT I found out that to fix this is to change the Shared IP: from my external IP to my Local IP.

Now all my websites are working :)
« Last Edit: April 30, 2016, 11:07:12 AM by kerfiseining »

Offline
*
Re: Default Page Displayed for all domains
« Reply #53 on: July 08, 2016, 08:29:48 AM »
 :(

same issues.. check all settings and forum post but no solution..
can anyone help me ?
my all website display default page.. i think vhost not work.. how can i fix it ?

Offline
*
Re: Default Page Displayed for all domains
« Reply #54 on: September 21, 2016, 05:00:32 PM »
What I realized that CWP Apache was not running, but default one was running, so as mentioned in the post below
http://forum.centos-webpanel.com/apache/warning!-you-are-not-running-cwp-apache/

New Installation
1. I had to fix the permission on the new account to server the page but when I
2. Reboot the System , it was loading default apache.

Clicking  [Try Fixing This] resolved the issue on one of my system.

To Determine the cause, we first need to determine which apache is running, If CWP Apache is running then the modifications will help otherwise kill all the apache process and launch the apache from within CWP Panel.

It would help to know what commands are run in the background when [Try Fixing This] link is clicked.


Offline
**
Re: Default Page Displayed for all domains
« Reply #55 on: September 25, 2016, 04:48:14 AM »
^^^ This happened to me recently. I noticed that the apache status was orange (subsystem still running). I tried a service httpd restart and it failed because it couldn't stop http. So a killall -9 httpd it was. Service httpd restart was reportedly successful but all domains gave the default test page. I followed the advice in this thread and nothing helped. A couple apache and vhost rebuilds and nothing. I logged out and logged back in and got the  "WARNING! You are not running CWP Apache and this could cause that your domains do not work!" error. Clicked "Try Fixing this" and it did.

I'm not sure what went wrong or how it was actually fixed so I don't really feel like I have complete closure on this issue.

Offline
*
Re: Default Page Displayed for all domains
« Reply #56 on: October 18, 2016, 03:25:25 PM »
I am aslo fighting for hours now to fix same issue.
Default page is showing up.
Followed all instructions here + http://wiki.centos-webpanel.com/default-page-displayed-for-all-domains

Problem still there.
vhost config is ok
Nat IP entered as per instructions

Help?  :P

Offline
*
Re: Default Page Displayed for all domains
« Reply #57 on: December 19, 2016, 02:22:20 PM »
I have just experienced this problem.
Thanks to @charliefinale. Your method resolved my problem.

To sum up, I deleted the user and recreate it with local IP (192.168.1.xxx) address rather than shared global IP address.
Global "index.html" (it is a welcome page) in "/usr/local/apache/htdocs" changed to user's index.html (it is a welcome page too) in user's public_html directory.

In addition, take into consideration that restart Apache WebServer in Services Status.

I have faced with the same situtation. At those times, I tried to configure CWP in home network and open to the worldwide.
Now, I am reconfiguring CWP in data center and trying to open to the worldwide again. Previous solution is not solving at this time.

I've just resolved my problem with these steps:
I have 2 dedicated ip address and 3 domains.
* I entered local ip address to Shared Ip in CWP Settings page.
* I didn't activated NAT-ed mode and not entered any IP there.
* I rebuilded Virtual Hosts in Apache Settings page.
* I restarted Apache Server in Dashboard page.
* I recreated user1 for domain1 with dedicatedIP1.
* I recreated user2 for domain2 with dedicatedIP1.
* I recreated user3 for domain3 with dedicatedIP2.
* I rebuilded Virtual Hosts in Apache Settings page as well
* I restarted Apache Server in Dashboard page as well.
Then, done!

Note 1: I'm only using Apache as webserver with 80 port.
Note 2: I switched Apache version to Apache/2.2.31 (Unix) from Apache/2.2.27 in "Apache Re-Build" page.
« Last Edit: December 19, 2016, 02:24:50 PM by ozgur »

Offline
*
Re: Default Page Displayed for all domains
« Reply #58 on: September 24, 2017, 05:29:57 AM »
changing <VirtualHost "public_ip":80>

to

<VirtualHost *:80>

worked for me. the site is still in test stage, I'm not sure if other issues will arise later due to this * setting.

Offline
*
Re: Default Page Displayed for all domains
« Reply #59 on: September 25, 2017, 01:28:43 PM »
worked for me. the site is still in test stage, I'm not sure if other issues will arise later due to this * setting.

Any rebuild will cause you the same issue again so its tbest to resolve the issue as * could cause you issue and requires manual changes.

try checking this instructions (all info should be there)
http://wiki.centos-webpanel.com/default-page-displayed-for-all-domains
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.